locked
SharePoint Designer Workflow Stuck on Starting after second document uploaded. RRS feed

  • Question

  • Hi,

     

    Got a really strange issue happening on one of my sites.  Basically a custom designer workflow for approval is used and when a new doc is created/uplaoded it starts and sends for approval.

    Now this runs fine with the first doc that has ever used the workflow however after that each worflow sits on starting and does not move??

     

    If I cancel the workflow and start it manually everything works.

    I created a new site and doc lib and tried a simple workflow that emailed me and it started every time?

    Has anyone experieced this?


    Update

    Speaking to the Admin for the server he tried it and every version he did started a workflow.

    Additioanlly I don't think there is a problem when I use the uplaod...very strange?

    Update 2:


    Could it be to do with my custom infopath information panel as when I remove x fields so that I just have a text box and lookup is seems to start failing.  If I keep the default it appears to work.

    • Moved by Mike Walsh FIN Monday, September 19, 2011 11:58 AM wf q so wf forum (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    • Edited by minority Monday, September 19, 2011 1:30 PM
    Monday, September 19, 2011 10:19 AM

Answers

  • I have worked it out to an extent that it not the workflow that the problem but it seem my custom documentation panel when I set a field to required seems to screw it up...if I leave it as optional all seems fine.
    • Marked as answer by Mike Walsh FIN Monday, September 19, 2011 5:34 PM
    Monday, September 19, 2011 2:47 PM