none
Site Permissions Needed to Use Designer

    Question

  • I have an Office 365 SharePoint site with various department sub-sites. A user from one of the department sub-sites wants to use Designer 2013 to manage the sub-site. I made her an owner of the sub-site but she still gets a permission denied message when trying to connect to the site with Designer 2013.

    What am I missing her?

    Thanks, Jim

    Thursday, March 16, 2017 8:08 PM

Answers

  • This info fixed my issue.  Thanks for those who replied.

    \http://blog.ciaops.com/2015/03/sharepoint-online-missing-web-designer.html

    Jim


    Goochland

    • Marked as answer by Goochland03 Monday, March 27, 2017 1:44 PM
    Monday, March 27, 2017 1:44 PM

All replies

  • Hi,

    Can you please try the following? YOu need to have permission at site collection level.

    https://support.microsoft.com/en-us/help/2592376/manage-permissions-and-control-access-to-sharepoint-designer

    Overall, an user needs to be a member of one of the following groups at the site collection level to be able to use SharePoint Designer and modify SharePoint content:
    • Site Collection Administrators
    • Designers
    • Owners


    Please remember to click Mark as Answer on the answer if it helps you

    Thursday, March 16, 2017 9:31 PM
  • Hi

    users should be owners and /or Designers to use it

    But you need to enable at site collection level

    More details , step by step here

    http://blog.ciaops.com/2013/06/disabling-sharepoint-designer-access-in.html


    Romeo Donca, Orange Romania (MCSE, MCITP, CCNA) Please Mark As Answer if my post solves your problem or Vote As Helpful if the post has been helpful for you.

    Thursday, March 16, 2017 10:03 PM
  • Are you saying at the top-level site versus the sub-site?  They are an "owner" of the sub-site.
    Friday, March 17, 2017 10:37 AM
  • They must be the owner of designers at site collection level.

    Please remember to click Mark as Answer on the answer if it helps you

    Saturday, March 18, 2017 5:20 AM
  • Hi Jim,

    Yes, you need to set user permission at site collection level, but sub site level.

    Also, please make sure that you have check Enable SharePoint Designer option to all site owners and designers to use SPD at site collection level.

    Best Regards,

    Dean Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, March 20, 2017 11:19 AM
    Moderator
  • Hi,
    Is there any update?
    If replies are helpful to you, you can mark as answer.
    Thanks,
    Dean Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, March 27, 2017 11:37 AM
    Moderator
  • So far, no.  Still not working.

    Goochland

    • Marked as answer by Goochland03 Monday, March 27, 2017 1:41 PM
    • Unmarked as answer by Goochland03 Monday, March 27, 2017 1:45 PM
    Monday, March 27, 2017 11:49 AM
  • This info fixed my issue.  Thanks for those who replied.

    \http://blog.ciaops.com/2015/03/sharepoint-online-missing-web-designer.html

    Jim


    Goochland

    • Marked as answer by Goochland03 Monday, March 27, 2017 1:44 PM
    Monday, March 27, 2017 1:44 PM