none
.Net Framework 4 Installation probem. RRS feed

  • Question

  • Greetings,

    I'm having few problems installing .Net Framework 4:

    1st I tried to install .net framewirk 4 64-bit standalone version, I run .exe as admin but nothing happend, computer becomes very slow and that's all. Even after 30 min setup doesn't start. In task menager there is actually setup running but it seems like it doesn't process. Then only way to stop it is by using 'end task' command.

    [url]http://www.imagebam.com/image/19b1af204567313[/url]

    I'm having same problem using WEB installer.

    Then I tried installing 3ds Max 2013, setup was installing few 3rd party programms and when it started installing .Net Framework 4 install just keept loading, computer was very slow again, then I thought it could simply take some time to install it so I left laptop on all night to finish installing. In the morning setup was still installing .net framework 4. So it seems like time isn't problem.

    I have uninstalled previous .net framework versions.

    My spec:

    [url]http://www.imagebam.com/image/6568c4204568090[/url]

    Thank you for any help.



    • Edited by IvarsT Sunday, August 5, 2012 8:50 AM
    Sunday, August 5, 2012 8:45 AM

Answers

  • The install never started. The failure occurred when the downloaded archive was decompressed:

    "Error 0x80070424: Failed to open the current cluster"

    This indicates either a corrupt download or a system issue on your side.

    Read the answers in these threads:

    http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/d2a454bf-b214-4dab-977c-6bc9355ddf67

    http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/db250587-0889-480f-a24f-e9197e9304ef

    You can also follow these steps:

    Follow ALL these steps exactly:

    Before trying to install .NET Framework 4.0, execute this command from an ELEVATED Command Prompt provided by the .NET Framework Team:

    "This issue is likely caused by a bad ACL on assembly\tmp folder. After installing updates, the ACL propagates to installed assembly folders in both 4.0 & legacy GAC.  If those updates were installed by WU or another user, the propagated ACL will prevent install of the same assembly by the current user.

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    After running that command, follow these steps:

    Please follow these instructions exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/en-us/download/details.aspx?id=17718

    2. Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Sunday, August 5, 2012 2:21 PM

All replies