none
My addin doesn't seem to work with Exchange 2013? RRS feed

  • Question

  • A customer of ours wants to use the Add-in we have developed for Outlook. They are trying to do that through Microsoft Exchange Admin Center. But they can't seem to enable the add-in in their Microsoft Exchange solution. It says that the version is not compatible with their version of Exchange.

    They are running Exchange 2013 with Outlook 2013.

    What do they need to do in order for them to be able to enable our add-in in all of their users Outlook?

    Do add-ins not work with Exchange 2013?

    Wednesday, March 28, 2018 7:00 AM

All replies

  • Hello maxpaj,

    Outlook add-ins could work with Exchange 2013

    According to Outlook add-in requirements, for Exchange, except version requirement(2013 or later), there are other three requirements. Please check if they meet all the requirements.

    1. The server must be Exchange 2013 or later.
    2. Exchange Web Services (EWS) must be enabled and must be exposed to the internet. Many add-ins require EWS to function properly.
    3. The server must have a valid authentication certificate in order for the server to issue valid identity tokens. New installations of Exchange server include a default authentication certificate. For more information, see Digital certificates and encryption in Exchange 2016 and Set-AuthConfig.
    4. In order to access add-ins from the Office Store, the client access servers must be able to communicate with https://store.office.com.

    Best Regards,

    Terry


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, March 29, 2018 5:49 AM
  • @Terry

    They already had EWS enabled.

    I got an error message from the customer now.

    The API version (1.3) required by this app isn't supported by the Exchange Server version (15.0.1236.3) that you're connecting to

    I'm using Mailbox API 1.3 in my addin. What do they need to do in order to install our addin?

    The version number seems to roughly equal to Exchange Server 2013 CU14:

    Exchange Server 2013 CU14

    September 20, 2016

    15.00.1236.003


    According to https://technet.microsoft.com/en-us/library/hh135098%28v=exchg.150%29.aspx?f=255&MSPPError=-2147217396





    • Edited by maxpaj Thursday, April 5, 2018 9:56 AM
    Thursday, April 5, 2018 8:54 AM