none
Issues with Kinect v2 + Surface tablets + Windows 10 RRS feed

  • Question

  • Hi

    We've been using Kinect v2 sensors for over a year now, most of the time tied to Surface 2 and Surface 3 tablets, all running Windows 8.1 ... so far, this has been the most stable configuration we've found regarding USB3 compatibility.

    Recently, we upgraded the Surfaces to Windows 10, at first everthing went fine, but recently, we're experiencing that the Surfaces are having a very hard time detecting the Kinect devices. This is happening with two Surface 2 and one Surface 3, and we have tried with 5 or 6 different sensors to discard device failure.

    It's not a problem of our software either, since Kinect Configuration utility is unable to run the kinect. Kinect configuration says everything is connected, but receiving zero frames.

    Also, when we conect a kinect to the USB, many times we get a notification about "Downloading..." something that never ends.

    We're in a hurry to get a solution on this, so, if it's not possible to get a solution through this board, we would like to know if it's possible to have direct assistance

    Thank you in advance.


    Vicente Penades

    Tuesday, January 19, 2016 9:10 AM

All replies

  • Good morning,

    1. you must make sure every OS update is done.

    2. second go to the intel site and download the latest Graphics drivers in zip format.  update the driver manually to this version.

    3. go to device manager and manually update drivers so all are updated.

    Surface 2 and 3 are working nice when all of this is done.

    David

    Tuesday, January 19, 2016 3:04 PM
  • Hi, thanks for the proposal, we tried it, unfortunately it didn't solve the problem for us:

    We installed the latest Intel graphics drivers  Win64 154014.4352 as per the instructions given here:

    http://www.windowscentral.com/how-install-intel-beta-graphics-drivers-surface

    After that, everthing seemed fine, but when trying with the Kinect Configuration Verifier, it failed in the last step, failing to receive any frames at all.

    We also tried with two sensors to discard harware failure.

    So from our side, this issue remains open.


    Vicente Penades

    Thursday, January 21, 2016 2:39 PM
  • You get 0 Frames on a Windows 10 Surface Pro 2 and 3?
    Thursday, January 21, 2016 3:02 PM
  • Yes, we have two Surface 2 and one Surface 3, all running Win10, plus 5 kinect v2 sensors.

    All the surfaces came with Win8.1 , and have been working fine with the sensors. We upgraded them to Win10 this last summer.

    It's been around last month the surfaces have stopped working with the sensors: Kinect configuration verifier gives the same diagnostic as before, but when it runs the sensor it gives zero frames instead the usal 30. Another thing is that when we plug the kinect USB to the surface, there's the "downloading..." popup that never ends.

    The only thing we have not tried is to reinstall windows. this is something we could do at our lab, but not something we can suggest to our partners.


    Vicente Penades

    Monday, January 25, 2016 8:33 AM
  • The only other thing I could suggest is removing the SDK and uninstalling the drivers.  Remove the Camera and plug it in again.

    Contact me via email and maybe I can have a quick look.  Should be working.

    david@kinetisense.com

    Monday, January 25, 2016 9:19 PM
  • We've managed to make them work, thank you anyway.

    Apparently the issue was related to the Redist VC++ 2012 Runtimes, we uninstalled/reinstalled them and it worked.

    We're not sure if it's related; these runtimes have been updated recently by microsoft through windows updates, our system shows:

    VC2012 redist runtime 11.0.60610 and 61030 have been updated December 9 of 2015

    VC2012 redist runtime 11.0.50727 has been updated Jan 7 of 2016

    So it leads me to think that maybe the issues some people is having are related to the Vc2012 redists.

    Thanks in advance!


    Vicente Penades

    Wednesday, January 27, 2016 11:01 AM