none
Access 2016 TextBox/Undo Typing Bug RRS feed

  • General discussion

  • Microsoft Office Professional 2016
    Version 1710 (Build 8625.2139 Click-to-Run)

    Summary:
    The second and third issuance of Ctrl-Z does not undo typing and/or does not fire the TextBox's Change event as expected. In one case, the bug or bugs continue in a cyclic fashion after closing and reopening the Form. The bug or bugs affect both bound and unbound TextBoxes. This may actually be a bug in the Undo Typing code, rather than in the TextBox code.

    To reproduce the issue:
    01. Create a new Form
    02. Place a Textbox on the Form
    03. Open the Form
    04. Type a character into the TextBox
    05. Press Ctrl-Z
    06. Type a character into the TextBox
    07. Press Ctrl-Z

          The TextBox's Change event does not fire.

    08. Type a character into the TextBox
    09. Press Ctrl-Z

         The character is not removed from the TextBox.
         The TextBox's Change event does not fire.

    10. Continue to hold down Ctrl-Z or press it again.

         The TextBox's Change event does not fire.

    11. Close the Form.
    12. Repeat steps 03 through 07
    13. Close the Form
    14. Open the Form
    15. Type a character into the TextBox
    16. Press Ctrl-Z

         The character is not removed from the TextBox
         The TextBox's Change event does not fire.

    17. Continue to hold down Ctrl-Z or press it again.

         The TextBox's Change event does not fire.


    • Edited by KorLibrary Wednesday, December 13, 2017 1:14 PM
    • Changed type KorLibrary Thursday, December 14, 2017 2:47 PM
    Wednesday, December 13, 2017 12:10 PM

All replies

  • Hello KorLibray,

    I could reproduce your issue. I would suggest you go to File->FeedBack to submit a feedback for the issue. If you have any other issue, please feel free to let us know too. Thanks for understanding.

    Best Regards,

    Terry


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, December 14, 2017 3:06 AM
  • Thanks, I already did. I have no idea if it actually worked, as the feature provided no feedback after I submitted the message. I figured that was what y'all were here for, so I posted it here. If I were a member of MSDN Community Support, I'd pass it on to the relevant party. It is a serious bug.






    • Edited by KorLibrary Thursday, December 14, 2017 2:45 PM
    Thursday, December 14, 2017 2:41 PM
  • Hi KorLibrary,

    Thanks for your feedback. Our forum support team does not have an internal channel to the Access product develop team. I would suggest you be patient to wait for response of your feedback. Thanks for understanding.

    Best Regards,

    Terry


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Monday, December 18, 2017 6:35 AM