locked
Windows Azure Pack - Service Bus 1.1 with TLS 1.2 Support RRS feed

  • Question

  • User-1789192319 posted

    Trying to in install "Windows Azure Pack: Service Bus 1.1 with TLS 1.2 Support" from web platform to provide TLS 1.2 support for Windows Azure Pack: Service Bus 1.1.

    I am getting following error. It looks like Web Platform downloads and installs the Windows Server version located here -> "https://support.microsoft.com/en-us/help/4077554/add-support-for-tls-1-1-and-tls-1-2-on-service-bus-for-windows-server", resulting in error. 

    ******************

    DownloadManager Information: 0 : Starting MSI install for msi 'C:\Users\pdsvcdvsp2016\AppData\Local\Microsoft\Web Platform Installer\installers\ServiceBus_1_1_TLS_1_2\8C05E213E366A846D87793E36ECA474F0C569B85\Service_Bus.msi', commandline: 'WEBPI=1 CEIP=1 ACTION=INSTALL REBOOT=ReallySuppress'
    DownloadManager Information: 0 : MSI install return value for product 'Windows Azure Pack: Service Bus 1.1 with TLS 1.2 Support' is '1638'
    DownloadManager Error: 0 : Install return code for product 'Windows Azure Pack: Service Bus 1.1 with TLS 1.2 Support' is Failure (Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel.)

    *************

    Friday, March 8, 2019 2:31 PM

Answers

  • User-1789192319 posted

    Fix is that Service Bus 1.1 and its updates needs to be uninstalled before we install "Windows Azure Pack - Service Bus 1.1 with TLS 1.2 Support".

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, March 12, 2019 12:56 PM

All replies

  • User690216013 posted

    "Windows Azure" is an obsolete term (today we call that Microsoft Azure), so you can know how old the thing is.

    DownloadManager Error: 0 : Install return code for product 'Windows Azure Pack: Service Bus 1.1 with TLS 1.2 Support' is Failure (Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel.)

    That means you already have the latest installed (maybe something called Microsoft Azure XXXXX) if you do check the installed program on this machine.

    Friday, March 8, 2019 3:26 PM
  • User-1789192319 posted

    Thank you for your response, lextm.


    What I need is TLS 1.2 support for Service Bus. I am not aware of any higher update which covers "Windows Azure Pack - Service Bus 1.1 with TLS 1.2 Support" 


    Here is extracted export of what is shown in Add/Remove program. Not able to attach screenshot properly

    Name Version
    Service Bus 1.1 2.0.30904.0
    Microsoft Sync Framework Runtime v1.0 SP1 (x64) 1.0.3010.0
    Microsoft Azure PowerShell - September 2016 2.1.0
    Microsoft Workflow Debugger v1.0 for x86 15.0.26208
    Workflow Manager Client 1.0 2.1.10607.2
    Microsoft Web Platform Installer 5.1 5.1.51515.0
    AppFabric 1.1 for Windows Server 1.1.2106.32
    Microsoft Workflow Diagnostic Pack for x64 15.0.26208
    Microsoft Azure Authoring Tools - v2.9.5.3 2.9.8699.20
    Microsoft Workflow Debugger v1.0 for amd64 15.0.26208
    Workflow Manager 1.0 2.0.40131.0
    Microsoft Azure Service Fabric 5.1.163.9590
    Workflow Manager Tools 1.0 for Visual Studio 2.1.10202.0

    Addremoveprogram

    Here is what is shown in Microsoft Web Platform Installer when you search for "Service Bus" 

     Windows Azure Pack - Service Bus 1.1 - Installed

     Windows Azure Pack - Security Update for Service Bus 1.1 (KB2972621) - Installed

     Windows Azure Pack - Service Bus 1.1 with TLS 1.2 Support - Add

    Web Platform Installer

    Saturday, March 9, 2019 12:01 AM
  • User690216013 posted

    Service Bus 1.1 2.0.30904.0

    Very likely this version already contains TLS 1.2 support and you don't need any extra.

    Here is what is shown in Microsoft Web Platform Installer when you search for "Service Bus" 

    My personal observation is that Web Platform Installer is on its dying road, so no need to focus on what it lists and says.

    BTW, what exactly are you trying to solve? If you want to make use of Microsoft Azure Service Bus, their latest supporting library is here,

    https://github.com/Azure/azure-service-bus-dotnet/tree/master

    Not an MSI installer any more.

    Saturday, March 9, 2019 5:20 AM
  • User-1789192319 posted

    Fix is that Service Bus 1.1 and its updates needs to be uninstalled before we install "Windows Azure Pack - Service Bus 1.1 with TLS 1.2 Support".

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, March 12, 2019 12:56 PM