locked
Invalid Key code in Crystalreport and vs2010 RRS feed

  • Question

  • Hello

    i install VS 2010 and then Crystal report for vs 2010 but when i add new item in project and choose crystalreport its ok but after add i get a message that contain "Invalid keycode"

    i read 2 article form this web site bout in final link was crashed how can i fix this problem

    thanks


    Hossein Aftabi http://www.internationalsell.com
    • Edited by H.Aftabi Friday, July 15, 2011 3:47 PM
    Friday, July 15, 2011 2:33 PM

Answers

  • thanks

    i told you , only install VS 2010 and CR 13-3-1

    ok

    i down load CR again from Here and install again 

    if it will ok , nothing and if not Ok i tell you again

    have a good time


    Hossein Aftabi http://www.internationalsell.com
    • Marked as answer by H.Aftabi Monday, July 18, 2011 5:59 PM
    Friday, July 15, 2011 8:19 PM

All replies

  • See if this link helps: http://forums.sdn.sap.com/click.jspa?searchID=73020079&messageID=10401174

    Also, make sure all of your references are version 13 for CR and that you are using Service Pack 1.

    Don


    Don Williams
    Friday, July 15, 2011 2:42 PM
  • if i understand you answer

    i first time after install Windows 7 i install VS201 and then SP1 for VS2010 and then CRforVS_13_0_1

    only


    Hossein Aftabi http://www.internationalsell.com
    Friday, July 15, 2011 2:52 PM
  • Correct....

    CR for VS 2010 does not require a keycode so it's picking up the info from a reference to an older version of CR runtime or something on your PC is corrupt, likely a previous version of Crystal Reports that was not installed or removed properly.

    Also see these article and SAP forum posts:

    http://forums.sdn.sap.com/thread.jspa?threadID=1985583

    http://forums.sdn.sap.com/thread.jspa?threadID=1860243

    And if you had a Beta version of CR for VS 2010 see this note:

    http://forums.sdn.sap.com/thread.jspa?threadID=1851043

    Don


    Don Williams
    • Proposed as answer by SAPDon Monday, July 18, 2011 1:23 PM
    Friday, July 15, 2011 6:05 PM
  • thanks

    i told you , only install VS 2010 and CR 13-3-1

    ok

    i down load CR again from Here and install again 

    if it will ok , nothing and if not Ok i tell you again

    have a good time


    Hossein Aftabi http://www.internationalsell.com
    • Marked as answer by H.Aftabi Monday, July 18, 2011 5:59 PM
    Friday, July 15, 2011 8:19 PM