locked
Web API Odata Tutorial Sample fails with HTTP Error 403.14 even after applying correction

    Question

  • The sample builds without errors, but it does not execute, it crashes with HHTP 403.14.

    The recommended solution of enabling directory browsing was applied, but the sample continues crashing.

    On another note, the instructions on the error listing mentioning the command :

    Things you can try:

    • If you do not want to enable directory browsing, ensure that a default document is configured and that the file exists.
    • Enable directory browsing.
      1. Go to the IIS Express install directory.
      2. Run appcmd set config /section:system.webServer/directoryBrowse /enabled:true to enable directory browsing at the server level.
      3. Run appcmd set config ["SITE_NAME"] /section:system.webServer/directoryBrowse /enabled:true to enable directory browsing at the site level.
    • Verify that the configuration/system.webServer/directoryBrowse@enabled attribute is set to true in the site or application configuration file.

    contain the wrong syntax or are outdated. Syntax error is received when you apply this, enabled:true, for example , does not exist in the current syntax.

    The solution that was used was listed under Microsoft's support:

    Method 1

    <script type="text/javascript">loadTOCNode(2, 'resolution'); </script>To resolve this problem, follow these steps:

    1. Start IIS Manager. To do this, click Start, click Run, type inetmgr.exe, and then click OK.
    2. In IIS Manager, expand server name, expand Web sites, and then click the Web site that you want to modify.
    3. In Features view, double-click Directory Browsing.
    4. In the Actions pane, click Enable.

    but, this does not solve the problem.

    Does anybody know the fix?

    Wednesday, May 15, 2013 2:38 PM

Answers

All replies