none
Cannot add extension 'RDP-xxxx-xxxx-xxxx-xxxx-xxxx' with same name space 'Microsoft.Windows.Azure.Extensions' and type 'RDP' more than once. RRS feed

  • Question

  • Hi!
    Im trying to create a RDP-user for a CloudService in Azure using the portal, but I keep getting the following error:
    Cannot add extension 'RDP-xxxx-xxxx-xxxx-xxxx-xxxx' with same name space 'Microsoft.Windows.Azure.Extensions' and type 'RDP' more than once.

    I have tried to create a new user with different username and password, I have tried to set the expire-date to different values and I have tried to do this all again in a different browser(IE)..

    Has anyone been able to get this working?
    Monday, August 11, 2014 10:50 AM

All replies

  • Hi,

    Are you trying to enable remote desktop in Azure ?

    Please have a check on the below link which talks about Configuring  the service for Remote Desktop access using Azure PowerShell.

    http://azure.microsoft.com/en-us/documentation/articles/cloud-services-nodejs-enable-remote-desktop/

    More information :

    http://www.dzone.com/articles/windows-azure-cloud-services-0

    Hope this helps.

    Regards,

    Mekh. 

    Monday, August 11, 2014 7:58 PM
    Moderator
  • I am having the same problem.  Here is how I got into this state:

    On 8/17, I published a web role to Staging (without Remote Desktop enabled)

    That same day, I enabled Remote Desktop via the portal, and set the account to expire on 8/18

    That same day, I swapped the role into Production, published another version to Staging, and again enabled Remote Desktop via the portal on the new Staging version, setting the account to expire on 8/18.

    On 8/19, I re-published the web role to Staging.  If I go to my staging server in Instances, the "Connect" button is enabled, but when I click it I cannot login with the account I configured on 8/17 since it has expired.  If I go to Configure, click the Remote button, and fill out the form, I get the error from the original post: "Cannot add extension 'RDP-xxxx-xxxx-xxxx-xxxx-xxxx' with same name space 'Microsoft.Windows.Azure.Extensions' and type 'RDP' more than once".

    I thought that re-publishing a web role without Remote Desktop would remove RDP...?

    I've tried doing a Reimage, and that didn't help.

    Next I'll try deleting my deployments and starting over.  But that shouldn't be necessary!

    Please advise on this.

    Tuesday, August 19, 2014 2:41 PM
  • I had similar problem, the issue I found was the password has similar / partial user name. (eg UName : CacheTest / Pass: Cache@123)

    When I change the user name to Test (name which is not part of password), RDP starts working. Hope it helps.

    Friday, January 9, 2015 1:19 PM