locked
Publish to my computer RRS feed

  • Question

  • I tried to publish my site from my hosting server to a folder on my computer. The first attempt failed, but the second try worked but...

    First in Windows Explorer I created a subfolder under My Web Sites (My Documents/My Web Sites/xxx). Next in EW4 I clicked on Site on the menu bar and opened my site on the server.  Next I selected Publishing Settings and pointed to the folder I created on my HD on my computer.  I then received an error message, "Folder does not exist, do you want to create the folder?"  I clicked on Yes.  (I checked and the folder did exist, but I selected the option to create it anyway.) Then I attempted to publish all files to this folder.   The site was then queued.  After over and hour the operation failed.

    Next I tried the same process again.  This time EW4 again said the folder did not exist, but when I chose the option to create the folder EW4 created a new folder xxx3, adding the 3 and published to this folder successfully.

    How do I publish to a folder on my HD with a name I select?

    Sunday, October 3, 2010 3:20 PM

All replies

  • Generally speaking, do all your file operations within EW. This enables EW to keep track using metadata, so if you move or rename a file or folder, it will automatically update all references.

    In the current instance, the way to go would have been to use Site|Open Site, then (if you're on Vista) you'll probably see the default Documents\My Web Sites\ at the top of the list. Select it, then right-click in the Folder List pane and choose New|Folder. You'll have the opportunity at that time to name it.

    There are other ways to accomplish this, but the point I'm trying to make is that EW is basically ignorant of changes that occur outside of its own file management system while it is open, unless it is refreshed.

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.
    Sunday, October 3, 2010 3:43 PM
  • Scott,

    I am running Window XP. When I select Site>Open Site, locations it does default to C:\Documents and Settings\my name\My Documents\My Web Sites.  When I click on the Open button, I get the folder list with my my other web sites.  At the very the top right there is a New Folder icon.  If I right click, as you suggest. in the folder list and select New I am present with 7 options - HTML, ASPX, ASP, PHP, CSS, Folder, and Subsite.  I have an ASP site on my hosting Windows server.  I want to have my site on my computer as a backup, and to be able to develop new pages or code changes, and then be able to publish these changes to my hosting server.  Of the 7 options should I select ASP or Folder?  The other option would be to click on the New Folder icon in the upper right of the folder list window.  Please advise

    Sunday, October 3, 2010 5:23 PM
  • Just create the folder and give it the name you wish to use locally. The other choices are for page types, as New|HTML page, or New|CSS Stylesheet, etc. (notice the separator bar between those selections and the Folder and Subsite selections).

    After you have the folder named and created, open your remote site and publish it down. Select the folder you just created to publish to. Sorry I can't give you step-by-step, but version 4 is the first one that I have actually used EW's FTP, having used external FTP clients previously. So, all of my sites already exist on my system and did not need to be published down.

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.
    Sunday, October 3, 2010 5:54 PM
  • Scott,

    I created the new folder, added it to my Site Settings as the default, Clicked on Publish All Folders to... (Ctrl+Sft+A) and after over 30 minutes nothing happens. (I am connected to the publishing destination and have the correct destination is the right pane.)  How do I start the publishing?

    Sunday, October 3, 2010 6:58 PM
  • Open EW, click Site > New Site give the new site a name and save it.
    Close the new site.
    Open the remote site.
    With the remote open click Site > Publishing and click:  Add publishing destination.
    Add the new empty site you just created as a publishing destination for the remote site.
    With the remote site still open, click Site > Publish all files.


    Expression Web MVP
    • Proposed as answer by Steve Easton Monday, October 4, 2010 2:30 PM
    Sunday, October 3, 2010 7:53 PM
  • I had this problem with a site, got frustrated, went to Filezilla and it was over and done with in 5 minutes. Since this site was using FPSE I called the host and asked them if this would crash the extensions...they said it shouldn't but if it did they would reinstall them for me and the tech guy watched me do it and there was no problems. I was moving the site from one computer to another computer.

     

    Sunday, October 3, 2010 8:15 PM
  • Thanks everyone.  I created the new folder and by clicking on Publish All Files a second time the Publishing operation started.  All is well.

    Moving from FrontPage to EW and then to EW4 has been a learning experience for this amateur.

    Sunday, October 3, 2010 8:27 PM