none
CU8 update on Biztalk 2013 R2 : Won't patch;Existing file is a lower version, installation error for some dll RRS feed

  • Question

  • Recently we have upgraded the Cumulative update from CU2 to Cu8 on biztalk 2013 r2. The installation completed with mesage "Installation succeeded but some post install action failed". In the setup log file we found that there were some dll's which do not get patched because of the following reason.

    1.) Overwrite; Won't patch; Existing file is a lower version

    2.) Won't patch; Existing file is unversioned and unmodified - hash doesn't match source file

    3.) Won't patch; Existing file is of an equal version

    4.) Won't patch; Existing file is unversioned and unmodified - no source file hash provided to compare

     Is there any solution to override the dll's which were not patched. 
    Wednesday, August 8, 2018 6:13 AM

All replies

  • Hi,

    Such type of error occurs when there are some Resources "orphaned" (left behind) with Windows Installers which never installed these component files and components registry entries left behind.

    When Windows Installer packages the MSI it built-up with some predefined Windows Installer Component Rules which causes errors mention in above points (refer Link#1)

    To understand your problem and give proper guidance request you to please provide detailed Setup Log.

    Link#1 https://docs.microsoft.com/en-us/windows/desktop/Msi/organizing-applications-into-components

    HTH


    Hope this Helps!!!! Regards, Note: Please Mark As Answered if you satisfy with Reply.

    Wednesday, August 8, 2018 11:17 AM