none
SP2013 on-prem: Quick Launch links stuck on the first one clicked RRS feed

  • Question

  • I believe this is a known issue (bug) and wanted to know if it has been fixed in latest patch:

    Quick Launch panel and 3 links to libraries: A, B, C

    Click A - A library opened and A is highlighted in the panel  (this is correct)

    Click B - B library opened but A is still highlighted in the panel

    Click C - C library opened but A is still highlighted in the panel

    Any one has any update on this issue?

    Thanks in Advance!

    Thursday, February 7, 2019 4:53 PM

All replies

  • Hi QuickLaunch, 

    What is the build number of your SharePoint farm? 

    Do you use Structural Navigation: Display the navigation items below the current site?

    I can not reproduce your issue in the SharePoint with ​December 2017 CU, you can try to install the latest cu. 

    Best Regards, 

    Lisa Chen 



    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, February 11, 2019 7:25 AM
    Moderator
  • Hey

    Can you upload a snapshot of your issue?

    I am not very clear about you mention.

    You may point to the default web browser hyperlink behavior.


    Justin Liu Office Apps & Services MVP, MCSE
    Senior Software Engineer
    Please Vote and Mark as Answer if it helps you.

    Monday, February 11, 2019 7:33 AM
  • Here is the behaviour:

    Action            Expected                   Actual

    Click Lib A     Lib A is highlighted     Lib A is highlighted

    Click Lib B    Lib B is highlighted     Still Lib A is highlighted (Lib B is not highlighted)

    Click Lib C    Lib C is highlighted    Still Lib A is highlighted (Lib C is not highlighted)


    (user looks the quick launch pane to select the library, but the selected lib is not highlighted, but the initial selected keeps highlighted, it is confusing to them)
    • Edited by QuickLaunch Monday, February 11, 2019 8:33 PM
    Monday, February 11, 2019 8:27 PM
  • Hi

    Do you mean the tree view?


    Justin Liu Office Apps & Services MVP, MCSE
    Senior Software Engineer
    Please Vote and Mark as Answer if it helps you.

    Tuesday, February 12, 2019 1:03 AM
  • Hi

    A few questions

    • Did you tried with another browser?
    • Are you having the same behavior in another sites? 
    • Do you know if all users are having the same issue? 

    I'm thinking that your issue is based on internet browser instead of SharePoint 


    Gabriel Edo. Sibaja | Comunidad SharePoint Costa Rica | Twitter: @Gabs_Sibaja | Blog: http://gabsibaja.blogspot.com | Please remember to mark the replies as answers if they help.

    • Proposed as answer by karimSP Tuesday, February 12, 2019 5:13 AM
    Tuesday, February 12, 2019 4:46 AM
  • not tree view, just basic Quick Launch panel on the left
    Tuesday, February 12, 2019 3:57 PM
  • this happens in our standard IE 11 browser

    this happens in all our users computers

    this happens in all our SharePoint sites

    Tuesday, February 12, 2019 3:58 PM
  • Hi QuickLaunch, 

    I can not reproduce your issue in the SharePoint with ​December 2017 CU, you can try to install the latest cu. 

    Best Regards, 

    Lisa Chen 


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, February 13, 2019 9:24 AM
    Moderator
  • Hi QuickLaunch, 

    Is there anything update? 

    If my reply is helpful to you, please remember to mark it as an answer. 

    Thanks for your understanding.

    Best Regards,

    Lisa Chen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.


    Monday, February 18, 2019 9:25 AM
    Moderator
  • this happens in our standard IE 11 browser

    this happens in all our users computers

    this happens in all our SharePoint sites

    What if you change the order of quick launch?

    Could you please create a new lib (new entry on QuickLaunch) and see if you are having the same behavior? 


    Gabriel Edo. Sibaja | Comunidad SharePoint Costa Rica | Twitter: @Gabs_Sibaja | Blog: http://gabsibaja.blogspot.com | Please remember to mark the replies as answers if they help.

    Monday, February 25, 2019 2:13 AM
  • It does not matter the order or new link or old link.   

    In each page session, the first link clicked on the left pane remains highlighted no matter what other links you click after that. It may confuse user as they expect the link clicked should be highlighted when the content opens in the page. In this case the content gets opened is the correct one, but the link highlight remains on the previously clicked link.

    Looks like our CU needs to be updated.

    Monday, February 25, 2019 3:38 PM
  • Hi QuickLaunch, 

    Install the latest cu, if there is anything update, feel free to let us know. 

    If a reply is helpful to you, please remember to mark it as an answer. 

    Thanks for your understanding. 

    Best Regards,

    Lisa Chen



    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, February 26, 2019 3:01 AM
    Moderator