none
What does 'ReadingModePrintedPage' do and how to set it. RRS feed

  • Question

  • I have a problem with Word 2013, which might be related to ReadView. It certainly showed up while we were solving whether of not a document loaded by an instance of Word running as a COM object would open in ReadView or PrintView. Perhaps more on that later, but my immediate  problem is an option which may or may not appear in HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Word\Options as ReadingModePrintedPage. It is present in about half or our QA teams machines, a fellow developer has it on her machine but it isn't on my machine. When this option is present and set to one, our application fails at:

         bShowHiddenText = (pView->SHowHiddenText != VARIANT_FALSE);

    with error
          800A11FD - The ShowHiddenText method or property is not available
                             because this command is not available for reading.

    If the 'ReadingModePrintedPage' is absent or set to zero, then there is no problem and we get the expected results. This piece of code has run quite happily since Word 97 days.

    I can find no reference to to the option or what it does (apart from crash our app), or how to set it. There are only 8 hits on Google and the are all self referential. So can anyone tell me:

    1) The purpose of the 'ReadingModePrintedPage' flag.
    2) How to set/unset it in Word 2013
    3) How to set/unset it via the COM interface.
    4) If there is any documentation, where can it be found.

    I should point out that our clients are reporting this problem and it will get worse as Word 2013 is rolled out to some 10,000 or so users.  

    Any help would be much appreciated.


    Oswy


    • Edited by Oswy Wednesday, August 19, 2015 3:22 PM
    Wednesday, August 19, 2015 3:15 PM

All replies

  • Hi Oswy,

    Can you set the 'Hidden Text' option manually? You can uncheck this option as figure below:

    I am not able to find the document about 'ReadingModePrintedPage' registry. You may consider to reopen a new thread in Word IT Pro Discussions forum to see whether it is relative to the option or so group policy.

    In addition, I am not able to find the Word object model that we can manipulate for this registry. You can recrod a macro to cofirm it if this regstry is relative to the opion in Word. As a workaround, I suggest that manipulate the registry via VBA directly.

    If you want Word to publish the object model to this registry, you can submit it via link below:
    Submit Feedback - Microsoft Support

    Regards & fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, August 20, 2015 2:35 AM
    Moderator
  • Thanks Fei,
    Perhaps I should make a couple of clarifications. This is a C++ application which runs Word entirely in automation, so user intervention isn't possible. Also the above case of trying to get the ShowHiddenText flag is only an example, any attempt to access Word level properties such as 'TrackRevisions', also fails. Further work this morning has shown the problem only happens when 'ReadingModePrintedPage' is set AND Word opens the document in ReadView. Unfortunately We have no control over the ReadView mode as it appears to be "sticky" from when Word was closed when it was last used. Unfortunately, adding VBA to many thousands of documents is not an option as many clients have macros turned off for security reasons.

    I'll follow up on the links you provided - for which, many thanks.


    Oswy


    • Edited by Oswy Thursday, August 20, 2015 8:33 AM
    Thursday, August 20, 2015 8:33 AM
  • Okay, a member of our QA team has kindly spent some time experimenting with Word 2013. She has discovered that 'ReadModePrintedPage' can be set by being in ViewMode, select View | Layout | Paper_Layout and then exiting from Word. It can be unset by selecting View | Layout | Column_Layout them, again, exiting from Word. It appears that the flag is only altered in the registry when Word exits, so appears to be "sticky".

    That's a big step forward, but I still need to be able to achieve the same result from the COM interface. I can't find any clues in the Object Model. Has anyone any ideas where to go next?


    Oswy


    • Edited by Oswy Thursday, August 20, 2015 3:08 PM
    Thursday, August 20, 2015 3:07 PM
  • Hi Oswy

    Hmm, I admit to being confused. I don't see any "Layout" group in the View tab of the Ribbon.

    Are you quoting this correctly? Or do you have an Add-in that's adding such a group? Or are you translating from a non-English interface?

    I do see: View/Views/Read Mode vs. Print Layout vs. Web Layout

    IF I'm in Read Mode, then I do see a View/Layout with the two options you mention.

    Looking at the object model for Word 2010 (you need to reference that version of Word, references to older versions will not work since the funcitonality is new in 2010!) I see any number of properties that pertain, for example:

    Document.ReadingModeLayoutFrozen
    Options.AllowReadingMode
    View.ReadingLayout
    View.ReadingLayoutActualView
    View.ReadingLayoutAllowEditing


    Cindy Meister, VSTO/Word MVP, my blog

    Thursday, August 20, 2015 4:53 PM
    Moderator
  • Hi Cindy,
    I'm working with a clean install of Word 2013. We don't have this problem in versions 97 to 2010. I load a document and it appears in ReadView (why in ReadView is a problem in its own right). Because we're in ReadView, there is no Ribbon, therfore:
    "If I'm in Read Mode, then I do see a View/Layout with the two options you mention."
    Spot on - that's exactly where I am. At this point in our application, most of the properties, like ShowHiddenText and many others are not accessible (error
     800A11FD), so we need to switch out of ReadView to PrintView. I've tried setting View->Type = wdPrintView, but it has no effect (but no error) until after Word has been shut down (not good when our app. has all its work still to do).  

    I have just discovered View.ReadingLayout, and View.ReadingLayoutActualView, which sound interesting. I hadn't discovered Option.AllowReadingMode which sounds particularly interesting, but I can't find the docs for View.ReadingLayoutAllowEditing. I think that it's about time I gave some of these a try to see if they solve our problem. In particular Option.AllowReadingMode which might do the trick. I'm sorry if this sounds a bit disjointed, but it's mid-evening here, and was due to start my 11 day summer vacation tomorrow.


    Oswy


    • Edited by Oswy Thursday, August 20, 2015 6:48 PM
    Thursday, August 20, 2015 6:48 PM
  • Hi Oswy

    21.00 hours, here... :-)

    Try the Options.AllowReadingMode one, before opening a document and see if that suppresses the mode.

    Word will tend to use this by default for documents opened from particular sources, such as email. 2010 is actually similar, but perhaps IT turned it off and hasn't done so for 2013?


    Cindy Meister, VSTO/Word MVP, my blog

    Thursday, August 20, 2015 6:56 PM
    Moderator
  • Hi Cindy,

    Another night owl ? It sounds like giving the Options a poke with a pointed stick might be the answer, as you suggest. I'll give it a go, and report back here.

    As a matter of interest, what we have found regarding ReadView is that, starting with no other instance of Word in memory...

    1) Load Word 2013 and create a simple document (A), and save it in PrintView.
    2) Create another document (B) and save in PrintView, close Word.
    3) Start a new instance of Word by clicking on document A, it loads in PrintView
    5) Select VIEW | Read Mode
    6) Save document A
    7) Exit Word so no instance of Word in Memory
    8) Click on document B to load it into a new instance of Word.
    9) You should observe that B is now in ReadView - it was in PrintView

    It seems that ViewMode is "Sticky" in Word 2013. If you have another instance Word in memory at the same time, you see an entirely different behavior. We've had much "fun" with this. My colleague from Q&A suggests "interesting" as a better qualifier.


    Oswy


    • Edited by Oswy Thursday, August 20, 2015 7:40 PM
    Thursday, August 20, 2015 7:40 PM
  • Hi Oswy,

    Thanks for the detail information for this issue.

    I am able to reproduce this issue now. Here is the steps:
    1. Create an new document

    2. Change it to paper layour

    3. Close and save the document

    4. Open the document and set the ShowHiddenText(failed)

    Please check whether the document is before change the showhidetext option. As far as I know, if the document is in read mode, then set ShowHiddenText would fail. We can chagne the mode to edit before change the option.

    Also here is an example via VBA for your reference:

    ActiveDocument.ActiveWindow.View.ReadingLayout = False
    ActiveWindow.View.ShowHiddenText = False
    Regards & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, August 21, 2015 2:14 AM
    Moderator
  • Hi Oswy

    <<It seems that ViewMode is "Sticky" in Word 2013. If you have another instance Word in memory at the same time, you see an entirely different behavior.>>

    FWIW Word has always saved the last View setting, which it uses when it opens or you create a new document. But it SHOULD be saving a document's setting and using that when the document is next opened.

    Admittedly, I haven't used 2013 or Reading Mode in 2010 very much, although I do let Word open Emails in Reading mode. So perhaps something has changed. I do know that Word 2013 no longer honors the Zoom percentage saved with a document and simply applies the available screen width for the screen where it opens which is a royal Pain.


    Cindy Meister, VSTO/Word MVP, my blog

    Friday, August 21, 2015 2:12 PM
    Moderator
  • Hi Cindy and Fei,
    I'm currently away from the office, on holiday. The above information has been acted on and when I left, it looks like it would solve the problems. I'll report back when 1st September, when I'm back in the office.


    Oswy



    • Edited by Oswy Tuesday, August 25, 2015 9:38 AM
    Tuesday, August 25, 2015 9:37 AM