none
Error: 18456, Severity: 14, State: 58. RRS feed

  • Question

  • Hi,

    I have a problem with Sql Server 2017 and domain users (with Active Directory 2012).

    When I try connect to Sql Server with "Active Directory - Password" with a domain user that it has permissions to access, I get thi error:

    Error: 18456, Severity: 14, State: 58.
    
    Login failed for user ''. Reason: An attempt to login using SQL authentication failed. Server is configured for Integrated authentication only. [CLIENT: <local machine>]

    I don't understand because the error is "Sql Autentication failed", when i using a domain user.

    Thanks.


    Monday, May 27, 2019 7:44 AM

Answers

  • When I try connect to Sql Server with "Active Directory - Password" with a domain user that it have permissions to access, I get thi error:

    I believe that this option only applies to Windows Azure. You cannot log into a local SQL Server instance with a Windows user and password. To log into an on-premise instance with Windows authentication, you need first log into to Windows one way or another.


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se

    Monday, May 27, 2019 9:27 PM

All replies

  • Good day ,

    1. Enable mixed mode authentication, and make sure that you restart the server

    https://docs.microsoft.com/en-us/sql/database-engine/configure-windows/change-server-authentication-mode?view=sql-server-2017

    2. Open SQL Server Configuration Manager and enable TCP in the network configuration (again, restart and make sure that all services related to the SQL server are running)

    >> Can you please provide full information from the SQL Server error log file

    >> Are you using SQL Server on Windows or any other OS or maybe you are using container?


    signature   Ronen Ariely
     [Personal Site]    [Blog]    [Facebook]    [Linkedin]

    Monday, May 27, 2019 2:02 PM
  • Gody day!

    1) Mixed mode is enabled

    2) TCP is enabled in network configuration

    I'm using Sql Server on Windows and in the log file (errorlog) is reported only:

    2019-05-27 09:44:32.38 Logon       Error: 18456, Severity: 14, State: 58.
    2019-05-27 09:44:32.38 Logon       Login failed for user ''. Reason: An attempt to login using SQL authentication failed. Server is configured for Integrated authentication only. [CLIENT: <local machine>]

    Monday, May 27, 2019 2:11 PM
  • hi,

    1. Please restart the server to make sure the configuration is kept and used while the services start

    2. make sure that all services related to the SQL server are running.

    3. Please try to connect using SQLCMD utility. If this works then you should probably check the connection string which you use.

    I noticed that the user name in the error message is empty... maybe this implies to the issue which is related to the connection string. It's like the server do not get the parameter for the user id. Please provide the connection string (Change the password into XXX and the user ID into YYY for security)


    signature   Ronen Ariely
     [Personal Site]    [Blog]    [Facebook]    [Linkedin]

    Monday, May 27, 2019 7:06 PM
  • When I try connect to Sql Server with "Active Directory - Password" with a domain user that it have permissions to access, I get thi error:

    I believe that this option only applies to Windows Azure. You cannot log into a local SQL Server instance with a Windows user and password. To log into an on-premise instance with Windows authentication, you need first log into to Windows one way or another.


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se

    Monday, May 27, 2019 9:27 PM
  • Hi Gianluca Carlesso,

    Could please try to excute select SERVERPROPERTY ( 'IsIntegratedSecurityOnly' )? Return of 1 means Windows authentication only; 0 means mixed mode; NULL means input is not valid, an error, or not applicable. 

    And then share us the result.

    Best regards,
    Cathy Ji


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Tuesday, May 28, 2019 10:58 AM
  • Ok, thanks.
    I read documentation and I think that this option only applies to Windows Azure.

    I use:
    runas /user:domain\user ssms.exe


    Wednesday, June 5, 2019 9:05 AM