none
User Settings issue

    Question

  • Hi

    I have updated to VS 2017 Community, including all updates.

    After installation, I tried out with projects from my previous VS 2015 and all worked fine and after a while I uninstalled my previous VS2015.

    '

    However, I can no longer access the User Settings. I typically access via Solution Explorer -> Project Name -> Properties -> Settings. I get this error in every case for every project:

    '

    An error occurred trying to load the page.
    Could not load file or assembly 'Microsoft.VSDesigner, Version=15.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

    '

    This means I can no longer edit/add/remove any settings.

    '

    One example: there is a user.config located in AppData -> ProjectName for  the project, and does contain the correct data. The project runs OK, and uses the settings correctly, and intellisense does list the correct settings when entering 'My.Setting.' - I just can't edit these settings at all.

    '

    The above error happens with all tabs in the settings window not only for the settings tab. All my other project run OK, but have exactly the same results when trying to access their user settings.

    '

    Has anyone else using VS2017 Communiy had this issue?


    Regards Les, Livingston, Scotland


    Thursday, March 16, 2017 8:06 PM

Answers

All replies

  • I think when you run the .exe from a new folder you get new settings. You have some settings for the bin folder in the Visual Studio that are save in the user settings but they point to the .exe running in vs 2015 somehow.

    You should have defaults for your settings in your app settings so the first time you run the .exe it makes the defaults. But if you move the .exe then you get new settings pointing to the new location and .exe.

    When you start your old apps in 2017 don't you get your default settings?

    PS Oh. Maybe that's not the problem?

    So you just cant open the project settings tab at all after you open an old project in vs 2017??

    Thursday, March 16, 2017 8:53 PM
  • Has anyone else using VS2017 Communiy had this issue?

    This is a VS issue, not a VB issue, and is best addressed in the VS forums.  See, for instance:
    https://developercommunity.visualstudio.com/content/problem/11826/could-not-load-file-or-assembly-microsoftvsdesigne.html

    It seems that you minimal installation needs some additional components.


    • Edited by AcamarMVP Thursday, March 16, 2017 9:11 PM
    • Proposed as answer by KareninstructorMVP Thursday, March 16, 2017 10:56 PM
    • Marked as answer by leshay Friday, March 17, 2017 2:46 AM
    Thursday, March 16, 2017 9:11 PM
  • Hi

    Your last sentence is it. Everything runs fine, using whatever the settings were in the old 2015 version, the usual project setting file is present and correct (I tried deleting it and recreate from project),  only when I open the usual setting dialog, it opens with all the tabs down the left side (Application, Resources, Settings etc), but all tabs produce the error message that I posted.

    Even when I clean project, rebuild project, save settings in code, nothing prevents that error.


    Regards Les, Livingston, Scotland

    Thursday, March 16, 2017 9:14 PM
  • Hi leshay,

    This forum discusses and asks questions about the Visual Basic programming language, Since your issue is more related to visual studio general, we'll move it to visual studio general forum for suitable support.

    Thanks for your understanding and cooperation.

    Best regards,

    Cole Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, March 17, 2017 1:48 AM
  • Hi

    Well, I uninstalled VS 2017 and re-downloaded/reinstalled just the same as I did the first time. The issue I had regarding the user Settings is now OKand all back to normal.

    I haven't had the set of Updates I had with the first installation yet, so I can only hope it wasn't that that caused my issue.

    I can't think of anything I did this time around that I didn't dolast time. The only thing that may be relevant is that I still had VS 2015 Community installed first time round and not for this installation.

    @Acamar- although I can't be sure, the information given at the link you posted does 'ring bells', but, as I say, I think I did the exact same for this working install - anyway, thnks for the pointer.

    Thanks for all contributions.


    Regards Les, Livingston, Scotland

    Friday, March 17, 2017 2:55 AM