none
AS2 - 'edi_DeleteNrrMessageContentEntry' Permissions RRS feed

  • Question

  • Has anyone ever seen a permissions issue like this before? I am currently trying to add a new trading partner to my AS2 solution. This partner is setup the same way as already functioning partners. I am using a 1 way send port, and the rest of the solution works just as expected (same host instances). Below is the error message that I get when the Send Port suspends.

    There was a failure executing the send pipeline: "Microsoft.BizTalk.EdiInt.DefaultPipelines.AS2Send, Microsoft.BizTalk.Edi.EdiIntPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Source: "AS2 encoder" Send Port: "AS2T_HTTP_Send_Test_AS2" URI: "http://someserver/as2" Reason: The EXECUTE permission was denied on the object 'edi_DeleteNrrMessageContentEntry', database 'BizTalkDTADb', schema 'dbo'.

    Any help is appreciated! Thanks,

    John

    Monday, April 29, 2013 4:45 PM

Answers

  • Hi,

    If you use Biztalk 2010 and have installed Microsoft BizTalk Server 2010 Cumulative Update 1 (CU1) or Microsoft BizTalk Server 2010 Cumulative Update 2 (CU2) on the computer, you could follow below KB. It will help you.

    http://support.microsoft.com/kb/2642402?wa=wsignin1.0 

    If not, please check the user's permission to make sure it has enough permission to execute 'edi_DeleteNrrMessageContentEntry'.

    Regards,


    Chen Yu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, May 3, 2013 7:12 AM
    Moderator
  • I am not sure why, but for some reason the BizTalk isolated host user did not have permissions to execute the stored procedure, 'edi_DeleteNrrMessageContentEntry'. I knew that this was the issue, but I wanted to find out more about the underlying cause, which I was unsuccessful with. I then gave the ISOHost user execute permissions, and its been running fine with no issues since.

    Thanks,

    John

    Friday, May 3, 2013 3:56 PM

All replies

  • Hi,

    If you use Biztalk 2010 and have installed Microsoft BizTalk Server 2010 Cumulative Update 1 (CU1) or Microsoft BizTalk Server 2010 Cumulative Update 2 (CU2) on the computer, you could follow below KB. It will help you.

    http://support.microsoft.com/kb/2642402?wa=wsignin1.0 

    If not, please check the user's permission to make sure it has enough permission to execute 'edi_DeleteNrrMessageContentEntry'.

    Regards,


    Chen Yu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, May 3, 2013 7:12 AM
    Moderator
  • I am not sure why, but for some reason the BizTalk isolated host user did not have permissions to execute the stored procedure, 'edi_DeleteNrrMessageContentEntry'. I knew that this was the issue, but I wanted to find out more about the underlying cause, which I was unsuccessful with. I then gave the ISOHost user execute permissions, and its been running fine with no issues since.

    Thanks,

    John

    Friday, May 3, 2013 3:56 PM