none
VS2010 suddenly can't attach Excel.exe any more. RRS feed

  • Question

  • Hi, team:

    I code an XLL project by VS 2010 Pro- ENG. At first, I can attach to an Excel.exe and debug my code. And then, after a few months, my xll surfers several crashes because of my code error. And now, the VS 2010 will be hanged there while clicking attach bottom. But it can also debug other code, not Excel XLL.

    Thanks,

    Gaoyang from Beijng

     
    Friday, August 16, 2013 8:10 AM

Answers

  • Hi Gaoyang.

    You can try this way to debug the XLL add in.

    In the Project Options window, specify the full path to excel.exe in Start External Program and run the project. see the figure below:

    Then add a breakpoint in your code and debug your XLL add in.

    Hope this will help you.


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Thursday, August 22, 2013 3:47 AM
    Moderator
  • Hi Gaoyang.

    Which version of Office is currently using?

    To diagnose this issue, here are some points we’d like you to check:

    Is the Add-in listed in Add-In Manager of Office and checked for using?

    Is the add-in shown in Disabled Application Add-ins in Excel Options?

    In addition, if convenient, you could describe the issue in detail and post the corresponding codes so that we could figure it out.

    Regards


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Wednesday, August 21, 2013 2:51 AM
    Moderator

All replies

  • Hi Gaoyang.

    Which version of Office is currently using?

    To diagnose this issue, here are some points we’d like you to check:

    Is the Add-in listed in Add-In Manager of Office and checked for using?

    Is the add-in shown in Disabled Application Add-ins in Excel Options?

    In addition, if convenient, you could describe the issue in detail and post the corresponding codes so that we could figure it out.

    Regards


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Wednesday, August 21, 2013 2:51 AM
    Moderator
  • Thanks for your reply!

    It is Office 2007 Pro ENG. The XLL type is Excel Add in, of course, is not disabled. 

    My case steps:

    1. Open VS2010, the project is based on the Excel2007 SDK, using C++.

    2. Open an Excel workbook.

    3. Add in the XLL generated by the project.

    4. Use the function of the XLL in the worksheet.

    5. In order to debug the code, attach the Excel.exe in VS2010, and the attach window is hanged there.

    Best Regards,

    Gaoyang 


    • Edited by 王高阳 Wednesday, August 21, 2013 5:42 AM
    Wednesday, August 21, 2013 5:34 AM
  • Hi Gaoyang.

    You can try this way to debug the XLL add in.

    In the Project Options window, specify the full path to excel.exe in Start External Program and run the project. see the figure below:

    Then add a breakpoint in your code and debug your XLL add in.

    Hope this will help you.


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Thursday, August 22, 2013 3:47 AM
    Moderator