locked
VS2019 - XAML Previewer rendering out of scale! RRS feed

  • Question

  • User97727 posted

    Dear,

    Everything worked correctly with the Visual Studio 2017, both using Xamarin Forms 3.4 or 3.6, but, after update to the Visual Studio 2019, I no more can use the XAML Previewer because it is rendering my pages out of scale.

    If I create a new project the pages are rendered correctly (at left on the below image), but if I copy a page from this new project and put in my project it is not rendered correctly (at right on the below image), but I cannot found how my project is influecing the XAML Previewer, this not happens in VS 2017.

    Please, somebody know a clue about that?

    Sunday, April 7, 2019 4:32 PM

Answers

  • User97727 posted

    Wowwwww! After seven days and near 36 hours of intensive/creative researching this issue I finally found the cause. I had the below change in the .user file of my android project:

    xml <AndroidDesignerPreferredDevice>my_pixel</AndroidDesignerPreferredDevice> to: xml <AndroidDesignerPreferredDevice>Nexus 4</AndroidDesignerPreferredDevice>

    The my_pixel was an old deleted image of android emulator. I no understand the why, but I found after a lot of work changing each detail/feature of my project comparing with a new project that working. When I was losing my hopes, I went to the last file, the .user file.

    Unfortunately this is just more one obscure problem that we need a lot of creative work to find the cause, that detonates our productivity. A feather, especially since Xamarin Forms is a great platform. :/ :s :'( :'(

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Saturday, April 13, 2019 12:23 AM

All replies

  • User180523 posted

    Is that the XAML Previewer built into Visual Studio 2019? You said you were using it in VS2017, so I'm thinking not. Are you referring to the Xamarin previewer? Because that's a dead project - end of life. See reference to the one now built into Visual Studio 2019.

    Sunday, April 7, 2019 10:01 PM
  • User97727 posted

    @ClintStLaurent said: Is that the XAML Previewer built into Visual Studio 2019?

    Yeeeeeeees, is that the XAML Previewer built into Visual Studio 2019!! Using the XF 3.6.

    You said you were using it in VS2017, so I'm thinking not. Are you referring to the Xamarin previewer? Because that's a dead project - end of life. See reference to the one now built into Visual Studio 2019.

    I was previously using the VS2017 successfully (within all its limitations), then I upgraded to VS2019, then there is this problem in rendering.

    :'( :'( :'(

    Sunday, April 7, 2019 10:20 PM
  • User378819 posted

    I had similar problems I updated my nuggets packages 1 to 1 and solved

    Wednesday, April 10, 2019 7:56 PM
  • User97727 posted

    Unfortunately this does not worked for me, I had updated all my nugget packages but the issue still happens.

    :'( :'( :'(

    Wednesday, April 10, 2019 10:01 PM
  • User97727 posted

    Wowwwww! After seven days and near 36 hours of intensive/creative researching this issue I finally found the cause. I had the below change in the .user file of my android project:

    xml <AndroidDesignerPreferredDevice>my_pixel</AndroidDesignerPreferredDevice> to: xml <AndroidDesignerPreferredDevice>Nexus 4</AndroidDesignerPreferredDevice>

    The my_pixel was an old deleted image of android emulator. I no understand the why, but I found after a lot of work changing each detail/feature of my project comparing with a new project that working. When I was losing my hopes, I went to the last file, the .user file.

    Unfortunately this is just more one obscure problem that we need a lot of creative work to find the cause, that detonates our productivity. A feather, especially since Xamarin Forms is a great platform. :/ :s :'( :'(

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Saturday, April 13, 2019 12:23 AM