locked
Cann't deploy WP 8.1 app to phone using VS 2013 - Error : DEP0001 : Unexpected Error: Element not found RRS feed

  • Question

  • I'm using VS 2013 express, update 3 (but what I'm about to say is still the same in update 2). I just created a new blank WP8.1 app, clicked Device and this happened:

    Build started: Project: 
    App1, Configuration: Debug Any CPU ------
    1>  App1 -> C:\Users\FVS\Desktop\App1\App1\bin\Debug\App1.exe
    2>------ Deploy started: Project: App1, Configuration: Debug Any CPU ------
    2>Error : DEP0001 : Unexpected Error: Element not found. (Exception from HRESULT: 0x80070490)
    ========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========
    ========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========
    I never could deploy an app to my phone (all kinds of app and languages). But when I use the tool to create store package and then deploy using the tool outside VS, it works just fine. In addition, I have an old solution for WP8 (created using VS2012 exp for WP), which is Xaml directX, this is only app I can deploy directly from VS2013 to my phone.
    • Edited by FVS922 Wednesday, July 16, 2014 1:55 PM
    Wednesday, July 16, 2014 1:54 PM

All replies

  • I'm hearing a lot of this lately.  Let me follow up with our product team to see what they say.

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    • Marked as answer by FVS922 Sunday, July 27, 2014 4:59 AM
    • Unmarked as answer by FVS922 Sunday, August 3, 2014 3:40 AM
    Wednesday, July 16, 2014 7:46 PM
    Moderator
  • Have they figured out what happened yet? I'm still stuck.
    Tuesday, July 29, 2014 4:36 AM
  • I still need the answer seriously.
    Tuesday, August 19, 2014 2:44 AM
  • I'm getting this too.

    Although this is with Unity 4.5.3f3, and primarily the media capture functionality from windows phone 8.1

    Wednesday, August 27, 2014 5:19 PM
  • Did this ever get fixed, as I just started getting it yesterday
    Friday, September 5, 2014 3:19 PM
  • I just made a new Unity project project and dragged all the scripts back in, it's probably some weird metadata issue with building not overwriting certain files
    Friday, September 5, 2014 3:41 PM
  • I am not using Unity, and have created a brand new universal app.  It is just a standard app, havnt changed anything.  Still getting the error.
    Thursday, September 11, 2014 8:20 PM
  • What OS / VS / Phone SDK version do you have installed? Your application, is it Silverlight or Universal? C++ or C#?

    Can you reset the device and retry?



    Thursday, September 11, 2014 10:31 PM
  • Win 8.1

    VS 2013 Ultimate Update 3

    Phone SDK - Not sure how to check the exact version

    Application is a plain Universal app (windows 8 version runs just fine, phone version in emulator works just fine)

    c#

    Here is a dump from my VS install

    Microsoft Visual Studio Ultimate 2013
    Version 12.0.30723.00 Update 3
    Microsoft .NET Framework
    Version 4.5.51641

    Installed Version: Ultimate

    Architecture and Modeling Tools   06181-004-0451047-02543
    Microsoft Architecture and Modeling Tools
       
    UML® and Unified Modeling Language™ are trademarks or registered trademarks of the Object Management Group, Inc. in the United States and other countries.

    Team Explorer for Visual Studio 2013   06181-004-0451047-02543
    Microsoft Team Explorer for Visual Studio 2013

    Visual Basic 2013   06181-004-0451047-02543
    Microsoft Visual Basic 2013

    Visual C# 2013   06181-004-0451047-02543
    Microsoft Visual C# 2013

    Visual C++ 2013   06181-004-0451047-02543
    Microsoft Visual C++ 2013

    Visual F# 2013   06181-004-0451047-02543
    Microsoft Visual F# 2013

    Visual Studio 2013 Code Analysis Spell Checker   06181-004-0451047-02543
    Microsoft® Visual Studio® 2013 Code Analysis Spell Checker

    Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

    The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

    Windows Phone SDK 8.0 - ENU   06181-004-0451047-02543
    Windows Phone SDK 8.0 - ENU

    Application Insights Tools for Visual Studio Package   1.0
    Application Insights Tools for Visual Studio

    ASP.NET and Web Tools   12.3.50717.0
    Microsoft Web Developer Tools contains the following components:
    Support for creating and opening ASP.NET web projects
    Browser Link: A communication channel between Visual Studio and browsers
    Editor extensions for HTML, CSS, and JavaScript
    Page Inspector: Inspection tool for ASP.NET web projects
    Scaffolding: A framework for building and running code generators
    Server Explorer extensions for Microsoft Azure Websites
    Web publishing: Extensions for publishing ASP.NET web projects to hosting providers, on-premises servers, or Microsoft Azure

    ASP.NET Web Frameworks and Tools 2012.2   4.1.21001.0
    For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

    ASP.NET Web Frameworks and Tools 2013   5.2.20703.0
    For additional information, visit http://www.asp.net/

    CodeMaid   #114
    CodeMaid is an open source Visual Studio extension to cleanup, dig through and simplify our C#, C++, F#, VB, XAML, XML, ASP, HTML, CSS, LESS, JavaScript and TypeScript coding.

    Written by Steve Cadwallader, for more information visit http://www.codemaid.net/

    Common Azure Tools   1.2
    Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

    GhostDoc   4.9.14150.0
    GhostDoc automatically generates XML documentation comments.

    InstallShield Limited Edition  
    InstallShield. For more information visit the Flexera Software website at <http://www.FlexeraSoftware.com>. Copyright © 2013 Flexera Software LLC. All Rights Reserved.

    JetBrains ReSharper 8.2   Full Edition build 8.2.0.2160 on 2014-03-21T02:53:08
    JetBrains ReSharper 8.2 package for Microsoft Visual Studio. For more information about ReSharper, visit http://www.jetbrains.com/resharper/. Copyright © 2003–2014 JetBrains, Inc.

    Microsoft Advertising SDK for Windows Phone  
    Microsoft Advertising SDK for Windows Phone
    Build

    Microsoft Azure Mobile Services Tools   1.2
    Microsoft Azure Mobile Services Tools

    NuGet Package Manager   2.8.50313.46
    NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

    PowerShell Tools   1.2
    Provides file classification services using PowerShell

    PreEmptive Analytics Visualizer   1.2
    Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

    SQL Server Data Tools   12.0.40403.0
    Microsoft SQL Server Data Tools

    VSColorOutput   1.4.5
    Color output for build and debug windows - http://blueonionsoftware.com/vscoloroutput.aspx

    Windows Phone 8.1 SDK Integration   1.0
    This package integrates the tools for the Windows Phone 8.1 SDK into the menus and controls of Visual Studio.


    • Edited by Jon Whiting Thursday, September 11, 2014 10:39 PM
    Thursday, September 11, 2014 10:38 PM
  • Deleted
    Monday, September 15, 2014 2:19 PM
  • i still have the same issue,please find asolution
    Tuesday, September 23, 2014 7:59 PM
  • Error code 0x80070490 might mean one of the following:

    1. One of the capabilities in the application manifest is not defined on the device;
    2. Application package database is corrupted, or update didn't go well.

    If [1] is the reason, could you manually uninstall the previous version of the app from the phone, remove all capabilities from the manifest, and redeploy?

    If it's because of the [2], the only solution would be to reset the device.

    Thursday, September 25, 2014 10:13 PM
  • I just got this too and I think I might be able to help steer Microsoft in the right direction.

    Backstory: I made an app for Windows Phone Silverlight 8.0 and I've been carefully and methodically transferring everything to Windows 8.1 XAML/Runtime (better stuff to take advantage of in 8.1 Runtime, like Universal).  I transferred some XAML and tested it, reworded some XAML from Silverlight to 8.1 and tested it...  then I added the "Microsoft Advertising SDK for Windows Phone 8.1 (XAML)" and everything went to hell; giving me the error

    "Error 1 Error : DEP0001 : Unexpected Error: Package could not be registered. (Exception from HRESULT: 0x80073CF6) StrykersAPFTCalcUniveral.WindowsPhone"

    Being a smart guy, I went in and removed the MS ADV SDK Reference and tested my app again thinking that all would be good... but I got stuck at the "Error 1 Error : DEP001" error again.  Guess the only way for me to get it back to a working state is to dump the solution and recreate from scratch... which doesn't suck too much for me because I'm just at the beginning of my transition from Silverlight to Runtime.

    Although, the question comes up as to what I'm going to do when it's time to put in MS ADV SDK. Hmmm...

    EDIT:  I created another Blank Universal App and started to transfer everything over again.  This time, I added the Ad SDK first and tested, added xmlns:UI and tested, added UI:AdControl and tested... and since everything looks okay, I'm going to go crazy transferring everything else over.

    POST-EDIT: Everything seemed to be going great.  Then I closed out of the solution and went back into it again and the error comes back when I go to run it on the emulator again.

    • Edited by Stryker2k2 Friday, March 20, 2015 1:49 AM
    Friday, March 20, 2015 1:13 AM
  • Getting the same error when trying to debug my WP8.1 app on newly installed VS2013 Prof Upd 4 running on Parallels Desktop 10 (OSX 10.10.2)
    • Edited by igorskyi Wednesday, March 25, 2015 6:12 AM
    Wednesday, March 25, 2015 6:11 AM
  • Hi all, 

    Make sure that application manifest contains only features supported by device. 

    And app manifest Package Name contains unique GUID 

    Thursday, April 30, 2015 12:25 PM