SQL Replication Error 17750 RRS feed

  • Question

  • Hi, I have been trying to create replication in SQL Server 2016 Standard, but getting below error 17750. Please let me know if any suggestions.

    Error Message:
    * Could not load the DLL xprepl.dll, or one of the DLLs it references. Reason: 2(The system cannot find the file specified). (Source: MSSQLServer, Error number : 17750) Get help: http://help/17750

    *The merge process was unable to deliver to the Subscriber. if using Web Synchronization, the merge process may have been unable to create or write to the message file. When troubleshooting, restart the synchronization with verbose history logging and Get help



    Monday, May 13, 2019 10:28 AM

All replies

  • Hi Chandra,

    If the DLLs for this are missing then you should try a repair of the SQL installation to resolve this issue.



    Monday, May 13, 2019 11:48 AM
  • Hi Matt,

    Thanks for your response, i have tried it twice but no luck it is same error again.



    Monday, May 13, 2019 12:57 PM
  • Did you try to copy the file from a working sql server?

    A Fan of SSIS, SSRS and SSAS

    Monday, May 13, 2019 2:10 PM
  • Hi Chandra,

    From your error information, please make sure your replication components are already installed. And please try to change default snapshot folder settings to fully qualified network name.
    Hope this could help you.

    Best regards,
    Cathy Ji

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact

    Tuesday, May 14, 2019 7:51 AM
  • could you please help me with filename, which all files needs to be copied from working SQL server

    Tuesday, May 14, 2019 9:58 AM
  • Hi,

    On the server that is missing this, you just need to add the 'SQL Server Replication' feature as it sounds like that isnt there.  If you run the installation media on that server and tick the box for 'SQL Server Replication' then that will add it.  Adding that one missing DLL wont help much if the rest of the feature isnt there.

    Give that a try and it should work :-)



    Tuesday, May 14, 2019 10:42 AM
  • could you please help me with filename, which all files needs to be copied from working SQL server

    Please make sure that the replication feature is installed. Based on the error message, the missing file is ..\Program Files\Microsoft SQL Server\MSSQL13.MSSQLSERVER\MSSQL\Binn\XPStar.DLL.

    A Fan of SSIS, SSRS and SSAS

    Tuesday, May 14, 2019 1:25 PM
  • i tried all these but still am getting same error, SQL version is below is there any other solutions

    Microsoft SQL Server 2016 (SP2) (KB4052908) - 13.0.5026.0 (X64)   Mar 18 2018 09:11:49   Copyright (c) Microsoft Corporation  Standard Edition (64-bit) on Windows Server 2016 Standard 10.0 <X64> (Build 14393: ) (Hypervisor)

    getting below error in Event Viewer Replication-Replication Merge Subsystem:agent failed. could not load the DLL xprep.dll, or one of the DLLs it references. Reason: 2(The System cannot find the file specified )


    Wednesday, June 26, 2019 3:04 PM
  • What type of the replication did you try to set up?

    A Fan of SSIS, SSRS and SSAS

    Wednesday, June 26, 2019 3:23 PM