locked
Not getting all the data from the stored procedure RRS feed

  • Question

  • Hi, I am new to SQL reporting services and currently trying to create a report using an existing stored procedure.

    Using the wizard I created a dataset and associated the stored procedure with it. When I go to the Data Tab and execute the stored procedure I am not getting all the rows back. I am getting around 100 rows although I am expecting more than 250 rows. I ran the SQL profiler and the parameters that are getting passed to the database when the stored procedure is run from the Data Tab is right. If I use the entry of SQL Profiler in the SQL Server Management Studio (copy and paste), I am getting the right information back (i.e., around 250+ rows).

    Till now I haven't set any filter on the dataset. A quick analsiys of the result reveals that there is an integer field in the database which is null for the missing records (This is my guess and I am not sure whether this is the cause of the problem).Is there any setting in the Visual Studio that I have to enable to see all the information in dataset (and which is not set by default)?

    Thanking in advance.

    Prashant

    Monday, December 4, 2006 10:08 PM

Answers

  • Thanks John for your reply. I deleted that dataset and created a new one. After that it's working fine. I think it was the problem with the initial dataset.
    Tuesday, December 5, 2006 3:41 PM

All replies

  • Are all 250 rows in a single result set, or are there multiple result sets output by the stored procedure?  If you haven't explicitly added any filters, then you should be seeing all of the rows in the report.  Have you applied any other grouping or aggregates which are perhaps collapsing some rows in your report?
    Tuesday, December 5, 2006 6:32 AM
  • Thanks John for your reply. I deleted that dataset and created a new one. After that it's working fine. I think it was the problem with the initial dataset.
    Tuesday, December 5, 2006 3:41 PM