locked
Can't install Visual Studio 2012 Professional with Blend on Windows 8 VM in VMWare

    Question

  • I am an App developer for "line of business" apps where I work. I have been developing them using visual studio 2012 professional with blend on a windows 8 virtual machine in virtual box. Our company recently moved our datacenter to VMware and I am currently in the process of recreating my development environment as a VM in VMware. The issue is every time I try to install visual studio it hangs at Applying MS Visual C++ compilers

    When I look at the resource monitor to see what process is blocking it, it looks like the installer is waiting on dwm.exe.

    I have left this machine running for more than 24 hours and it is still at the same amount of progress. I am using the local administrator account to do the install and have disabled windows defender (which is the only virus protection I have on her). I have also tried the install with the O.S. up to date and with the O.S. freshly installed with no updates. Please help.

    Friday, June 27, 2014 6:13 PM

Answers

  • I figured it out. I had VMTools installed before installing visual studio. I uninstalled VMTools and install visual studio first. Then installed VMTools and now visual studio is installed.
    Tuesday, July 1, 2014 7:56 PM

All replies

  • Maybe kill dwm.exe? Is your Windows 8 install completely updated?

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Friday, June 27, 2014 7:13 PM
    Moderator
  • I did try that and it was still blocking the installer.
    Friday, June 27, 2014 7:24 PM
  • I figured it out. I had VMTools installed before installing visual studio. I uninstalled VMTools and install visual studio first. Then installed VMTools and now visual studio is installed.
    Tuesday, July 1, 2014 7:56 PM