none
Problem with multiple Kinect camera's RRS feed

  • Question

  • When connecting 2 camera's to my notebook, the device drivers for the second camera fails to start (This device cannot start. (Code 10)). Other Kinect device drivers (Kinect device, USB Audio and Audio Array) are installed correctly for the second camera.

    Devices are connected to another USBhub, I tried rebooting my notebook which doesn't work either. Both camara's work well if connected seperately.

    Tuesday, June 28, 2011 12:06 PM

Answers

  • Devices are connected to another USBhub

    Hi do you mean they are connected to a single USB port on the laptop via a USB hub?  If so this may be the problem, the data rate of the kinect is high enough that it will need a usb 2.0 bus to itself.  The experiments I've known where multiple kinects were connected involved a second USB card being installed in the machine.  Though these experiments were being done using the OpenNI framework - I'm not sure if the SDK will definitely support more than 1 sensor.
    Tuesday, June 28, 2011 4:02 PM

All replies

  • Devices are connected to another USBhub

    Hi do you mean they are connected to a single USB port on the laptop via a USB hub?  If so this may be the problem, the data rate of the kinect is high enough that it will need a usb 2.0 bus to itself.  The experiments I've known where multiple kinects were connected involved a second USB card being installed in the machine.  Though these experiments were being done using the OpenNI framework - I'm not sure if the SDK will definitely support more than 1 sensor.
    Tuesday, June 28, 2011 4:02 PM
  • You will probably get in trouble with the infrared. Every Kinect has the same infrared frequency. So you maybe have to rapidly switch on/off.

    Wednesday, June 29, 2011 10:44 AM