locked
Why don't I have contributor rights? RRS feed

  • Question

  • I'm evaluating TFS using a workgroup edition.

    Apparently I have no contritutor rights. When I right click the project node in VS it says No Commands Available. I can see the files and folders in the source control explorer but all check in, check out etc operations are disabled.

    I'm a member of the following groups (UnikTest is the name of the project in question):
    • [SERVER]\Team Foundation Licensed Users
    • [UnikTest]\Contributors
    • [UnikTest]\Project Administrators
    The project groups are members of the Team Foundation Valid Users group. The project was created using a wizard.

    The TFS user used to setup TFS, SharePoint and Reporting services has contributor rights (can add files and folders etc.). I've followed the guide Team Foundation Server Contributor Permissions.

    I'm rather certain that there are no Deny permissions anywhere. Any suggestions why I have no contributor rights?
    Friday, November 10, 2006 9:46 AM

Answers

  • At last I found the answer! I thought everything would be alright when I did all the configuration listed above. However, a few setting were missing. How to: Configure Visual Studio with Team Foundation Source Control: "In the Current source control plug-in list box, click Visual Studio Team Foundation Server.".

    Thanks, but when the above settings have been made you're automatically requested to select a local folder to check out to. So the clue is the missing context menues indicating that source control plug-in isn't enabled.
    Friday, November 10, 2006 2:55 PM

All replies

  • Do you have a workspace created for the source repository?  You wouldn't be able to check out/check in unless you've already created a workspace and mapped those folders do your local machine.

    Can you create/edit workitems?

    Friday, November 10, 2006 2:15 PM
    Moderator
  • At last I found the answer! I thought everything would be alright when I did all the configuration listed above. However, a few setting were missing. How to: Configure Visual Studio with Team Foundation Source Control: "In the Current source control plug-in list box, click Visual Studio Team Foundation Server.".

    Thanks, but when the above settings have been made you're automatically requested to select a local folder to check out to. So the clue is the missing context menues indicating that source control plug-in isn't enabled.
    Friday, November 10, 2006 2:55 PM
  • Great, glad to know it's working for you now.
    Friday, November 10, 2006 4:23 PM
    Moderator