BizTalk Map Test output is empty + EDI 835 RRS feed

  • General discussion

  • Hi , 

    I created 2 map's for converting EDI 835 ( Version 4010 and 5010) to Internal XML format.

    Version 4010 of map when tested is converted to a Internal format properly.

    when testing the 5010 version of the EDI, I get an empty XML, which is below

    <ns1:Message835  xmlns:ns0="" />

    I am unable to understand why? Any suggestions please.



    Monday, October 8, 2012 6:09 PM

All replies

  • Are you using external xslt map, if so, make sure you changed the root node in the 5010 to internal xml map?
    4010 root node is X12_00401_835 and 5010 root node is X12_00501_835.
    Target name space is same for both,, so no changes here.

    Monday, October 8, 2012 11:13 PM
  • Hello Bhava,

    Thanks for the reply.

    No there isnt any external xslt map. 

    Any other suggestions?



    Tuesday, October 9, 2012 1:27 AM
  • Debug is the best option here, right click on the .btm(map) file, select "Debug Map", it should generate the .xsl file temporay folder, step through the map (F11) and verify why expected templates are not being executed.

    Tuesday, October 9, 2012 1:40 AM
  • Version 4010 and 5010 will not generate the same input XML (the root-element will differ etc.), so you cannot use the same map for 4010 and 5010.

    Morten la Cour

    Wednesday, October 10, 2012 10:41 AM
  • Thats right,

    I am not using the same map. I have 2 different maps for each.

    4010 Map output is fine. 5010 map when tested just returns empty output with root elements.

    I started to create a new map again from scratch and did only basic mapping of elements and I see output. I guess something is going wrong in the map.

    when I debug Visual is crashing


    Wednesday, October 10, 2012 12:49 PM
  • I remember having the same issue sometime ago.

    Do you run Win 7, 64 bit?
    Did you have any extenestions installed(VS.NET productivity power tools etc), if so can you disable them and try to debug?

    Wednesday, October 10, 2012 7:12 PM