none
Can't install .NET 2.0 runtime??? RRS feed

  • Question

  •  

    I've freshly built Windows XP machine with all Windows updates in place.  (SP2 and Windows Installer 3.1).

     

    I downloaded the .NET 2.0 runtime (dotnetfx.exe) 32 bit for x86 and when I try to run the installer I see it unpack all the files but the second it starts the install I get

     

     error -1073741811

     

    I've searched the knowledge base and found nothing related to to this error code.  (Gawd how I hate the knowledge base)

     

    Can anyone shed light on what is causing this?

     

     

    Tuesday, April 1, 2008 7:32 PM

Answers

  • Problem solved...

     

    I got tired of mucking around with it.  Formated hard drive, reinstalled XP again, did all updates and then installed .NET 2.0.  Did updates again and installed .NET 2.0 SP1.  All seems to be working.

     

    Thursday, April 3, 2008 3:40 PM

All replies

  • Can you check your application event log and see if there is more information?

    Tuesday, April 1, 2008 7:44 PM
  •  Chris Eargle wrote:

    Can you check your application event log and see if there is more information?

     

    Two entries in the log.

     

    1. Application Error Event 1000    This simply tells me the error was in "install.exe" and refers to the second error entry

     

    2. Application Error Event 1001    Fault Bucket   251546839

     

     

    I went ahead and clicked to send to MS and the return was something having nothing at all to do with the .NET installer.  (Talked about Terminal Services that are not on this machine.)

     

    Tuesday, April 1, 2008 7:58 PM
  •  AustinMyers wrote:

    I've freshly built Windows XP machine with all Windows updates in place.  (SP2 and Windows Installer 3.1).

    I downloaded the .NET 2.0 runtime (dotnetfx.exe) 32 bit for x86 and when I try to run the installer

     

    If you've installed all the Windows updates, shouldn't you already have .NET 2.0 SP1 installed?

    Tuesday, April 1, 2008 10:19 PM
  •  Chris Eargle wrote:
     AustinMyers wrote:

    I've freshly built Windows XP machine with all Windows updates in place.  (SP2 and Windows Installer 3.1).

    I downloaded the .NET 2.0 runtime (dotnetfx.exe) 32 bit for x86 and when I try to run the installer

     

    If you've installed all the Windows updates, shouldn't you already have .NET 2.0 SP1 installed?

     

    No. apparently not.  In fact add/remeove doesn't show it (.NET) like on any other XP box I have seen.

    Tuesday, April 1, 2008 10:24 PM
  • Hi

    Can you run the .NET 2.0 setup again, and if it fails please follow What to do when you go to post a setup and deployment issue on the MSDN forums?
    http://blogs.msdn.com/aaronru/archive/2007/12/10/what-to-do-when-you-go-to-post-a-setup-and-deployment-issue-on-the-msdn-forums.aspx for more information.

     

    Thanks

    Thursday, April 3, 2008 3:09 AM
  • Problem solved...

     

    I got tired of mucking around with it.  Formated hard drive, reinstalled XP again, did all updates and then installed .NET 2.0.  Did updates again and installed .NET 2.0 SP1.  All seems to be working.

     

    Thursday, April 3, 2008 3:40 PM