none
Cannot Delete or publish any project..Please help RRS feed

  • Question

  • Hello, 

    We are using PS2007 SP2 in my company to manage our projects.

    Last week, we had a problem and so far it is still unresolved.

    We tried to make publish for a project through MS Project Professional 2007, But the process has not been completed although it is written on the taskbar that the process will take 60 seconds.

    Now on the queue, the process(Publishing the project) is still under construction (Waiting to be processed).

    We tried to delete this project, But the process has not been done and is still in the queue (Waiting to be processed).

    We tried to make a new project, But the process has not been done and is still in the queue (Waiting to be processed).

    We checked the event viewer, but no errors there.

    At this time, the work is stopped in the company because of this problem.

    Please help us to overcome this problem.

    Thanks in advance, 

     

    Scott.

    Wednesday, September 8, 2010 7:24 AM

Answers

  • Hi rockstorm,

    Have you verified that the queue service is till running (Start -> Administrative Tools -> Services)?
    Try restarting the Microsoft Project Server Queue Service and see if the jobs gets processed.

    If not, it might be that the publishing queue job is stuck in the queue for some unknown reason and is blocking other queue jobs to complete (or even start). In this case, you can try the following:

    • Go to Project Web Access -> Server Settings -> Manage Queue
    • Verify that the publishing process is the oldest job 'Waiting to be processed'
    • Select the publishing job and select 'Cancel job' (all related jobs will also be published)

    You should now be able to publish, delete, ... the project again.

    I hope this helps,
    Hans


    My EPM blog: Projectopolis
    • Marked as answer by rockstorm Thursday, September 9, 2010 7:12 AM
    Wednesday, September 8, 2010 7:31 AM
    Moderator

All replies

  • Hi rockstorm,

    Have you verified that the queue service is till running (Start -> Administrative Tools -> Services)?
    Try restarting the Microsoft Project Server Queue Service and see if the jobs gets processed.

    If not, it might be that the publishing queue job is stuck in the queue for some unknown reason and is blocking other queue jobs to complete (or even start). In this case, you can try the following:

    • Go to Project Web Access -> Server Settings -> Manage Queue
    • Verify that the publishing process is the oldest job 'Waiting to be processed'
    • Select the publishing job and select 'Cancel job' (all related jobs will also be published)

    You should now be able to publish, delete, ... the project again.

    I hope this helps,
    Hans


    My EPM blog: Projectopolis
    • Marked as answer by rockstorm Thursday, September 9, 2010 7:12 AM
    Wednesday, September 8, 2010 7:31 AM
    Moderator
  • It is also possible rockstorm to see the service running, but the instance of the service that processes the queue jobs did not start correctly.  If you open Task Manager you should see at least two instances each of the Queue and Event services for Project Server.  If you just see one of either then check the ULS logs to see if there is a problem starting the queue.  Stopping and re-starting the service should give you a fresh error message rather than digging through all your logs.

    Best regards,

    Brian.


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Wednesday, September 8, 2010 10:38 PM
    Owner
  • Hello Hansh and Brian,

    I want to thank you all for replying me and My problem has been resolved.

    I first checked the ULS logs, but no errors found there. I tried restarting the Microsoft Project Server Queue Service, Then all outstanding tasks in the queue disappeared. I then tried to Delete a project plan and the operation completed successfully.

    Thanks all, I appreciate.

     

    Scott.

    Thursday, September 9, 2010 7:12 AM