none
Unable to add reference to bing maps in one particular app RRS feed

Answers

  • My guess is the non working project does not have some project definition expected of a .NET Windows Store app. Compare the two project files line by line and see if you can spot any differences.
    Tuesday, November 6, 2012 4:32 PM

All replies

  • My guess is the non working project does not have some project definition expected of a .NET Windows Store app. Compare the two project files line by line and see if you can spot any differences.
    Tuesday, November 6, 2012 4:32 PM
  • What do you mean by "project file" -- app.xaml or app.xaml.cs or something else?
    Tuesday, November 6, 2012 4:51 PM
  • The .csproj file.

    Tuesday, November 6, 2012 7:02 PM
  • I noticed that the app that IS working with Bing Maps has this in the .csproj file, whereas the other one doesn't:

    <Compile Include="DataModel\SampleDataSource.cs" />
        <Compile Include="Common\BindableBase.cs" />
        <Compile Include="Common\BooleanToVisibilityConverter.cs" />
        <Compile Include="Common\BooleanNegationConverter.cs" />
        <Compile Include="Common\LayoutAwarePage.cs" />
        <Compile Include="Common\RichTextColumns.cs" />
        <Compile Include="Common\SuspensionManager.cs" />
        <Compile Include="SQLite.cs" />
        <Compile Include="SQLiteAsync.cs" />
        <Compile Include="ViewModel\StorageUtils.cs" />
        <Compile Include="View\SectionN.xaml.cs">
          <DependentUpon>SectionN.xaml</DependentUpon>
        </Compile>

    ...although curious (why does one include all of those files, and the other doesn't?), I don't see why this would be a problem.

    Also, the working app contains this:

    </PropertyGroup>
      <PropertyGroup Condition="'$(Configuration)|$(Platform)' == 'TSLsARM|AnyCPU'">
        <DebugSymbols>true</DebugSymbols>
        <OutputPath>bin\TSLsARM\</OutputPath>
        <DefineConstants>DEBUG;TRACE;NETFX_CORE</DefineConstants>
        <NoStdLib>true</NoStdLib>
        <DebugType>full</DebugType>
        <PlatformTarget>AnyCPU</PlatformTarget>
        <UseVSHostingProcess>false</UseVSHostingProcess>
        <ErrorReport>prompt</ErrorReport>
        <CodeAnalysisRuleSet>MinimumRecommendedRules.ruleset</CodeAnalysisRuleSet>
        <Prefer32Bit>true</Prefer32Bit>
      </PropertyGroup>
      <PropertyGroup Condition="'$(Configuration)|$(Platform)' == 'TSLsARM|ARM'">
        <DebugSymbols>true</DebugSymbols>
        <OutputPath>bin\ARM\TSLsARM\</OutputPath>
        <DefineConstants>DEBUG;TRACE;NETFX_CORE</DefineConstants>
        <NoWarn>;2008</NoWarn>
        <NoStdLib>true</NoStdLib>
        <DebugType>full</DebugType>
        <PlatformTarget>ARM</PlatformTarget>
        <UseVSHostingProcess>false</UseVSHostingProcess>
        <ErrorReport>prompt</ErrorReport>
        <CodeAnalysisRuleSet>MinimumRecommendedRules.ruleset</CodeAnalysisRuleSet>
        <Prefer32Bit>true</Prefer32Bit>
      </PropertyGroup>
      <PropertyGroup Condition="'$(Configuration)|$(Platform)' == 'TSLsARM|x64'">
        <DebugSymbols>true</DebugSymbols>
        <OutputPath>bin\x64\TSLsARM\</OutputPath>
        <DefineConstants>DEBUG;TRACE;NETFX_CORE</DefineConstants>
     . . .

    Friday, November 9, 2012 3:15 PM