locked
trying to install net framework 3.5 on VM Windows 2016 RRS feed

  • Question

  • I would like to install .NET Framework 3.5 on Windows Server 2016 VM . Please see error messages below. 

    PS C:\Users\veryimportantpu> Add-WindowsFeature NET-Framework-Core

    Add-WindowsFeature : The request to add or remove features on the specified server failed.

    Installation of one or more roles, role services, or features failed.
    One or several parent features are disabled so current feature can not be enabled. Error: 0xc004000d

      + CategoryInfo          : InvalidOperation: (@{Vhd=; Credent...Name=localhost}:PSObject) [Install-WindowsFeature],

        Exception

     + FullyQualifiedErrorId : DISMAPI_Error__Failed_To_Enable_Updates,Microsoft.Windows.ServerManager.Commands.AddWind owsFeatureCommand+ Add-WindowsFeature NET-Framework-Core


    Thursday, September 13, 2018 9:36 PM

All replies

  • You should be able to enable this using Windows Features rather than PowerShell. 

    If you open a search in your VM and look for Windows Features you then pick Tun on or off Windows Features 

    Then you can enable it from there

    Thursday, September 13, 2018 11:38 PM
  • I have the same problem.  @Micah the solution you're proposing won't work because this is server 2016.  It tries to go through the add/remove server features workflow.  And when trying to do that it says the source files are missing.  My issue is on an Azure VM so I can't mount any ISO to get the files.  I know there must be a solution to this because lots of software is run on these servers that required .NET framework.  Any help??

    Note that I opened an Azure support ticket also and I've been routed to 2 teams now with no solution.  Hopefully the 3rd team that I talk to will be able to help.  Ticket #118091319002082

    • Edited by KumoJosh Friday, September 14, 2018 7:09 PM
    Friday, September 14, 2018 7:05 PM
  • Thanks for those details. 

    I just tried on a new Server 2016 machine and it appeared to have worked

    So generally this would be the correct route to take. 

    If you are seeing something different than it is likely something with your specific VM unfortunately. I will check in on the ticket to see if I can suggest anything. Apart from that, I would suggest you make sure you are fully up to date on Windows updates to see if it helps. 

    Saturday, September 15, 2018 1:58 AM
  • I would like to install .NET Framework 3.5 on Windows Server 2016 VM . Please see error messages below. 

    PS C:\Users\veryimportantpu> Add-WindowsFeature NET-Framework-Core

    Add-WindowsFeature : The request to add or remove features on the specified server failed.

    Installation of one or more roles, role services, or features failed.
    One or several parent features are disabled so current feature can not be enabled. Error: 0xc004000d

      + CategoryInfo          : InvalidOperation: (@{Vhd=; Credent...Name=localhost}:PSObject) [Install-WindowsFeature],

        Exception

     + FullyQualifiedErrorId : DISMAPI_Error__Failed_To_Enable_Updates,Microsoft.Windows.ServerManager.Commands.AddWind owsFeatureCommand+ Add-WindowsFeature NET-Framework-Core


    @Very, @KumoJosh, Kindly try the suggestions posted by Micah above and let us know the outcome for further investigation on this issue.

    Monday, September 17, 2018 11:06 AM
    Owner
  • @Micah, you were correct for my issue.  I ran all available windows updates for the machine, rebooted and then when I went to install it via the wizard, it actually said it was already installed.  Not sure how it was installed but one of the updates must have installed it.

    Thanks for you help.

    Thursday, September 20, 2018 12:25 AM
  • @KumoJosh, Glad to know the issue is resolved after installing the Windows Updates as suggested by Micah. If the above post provided by Micah was helpful, please do click ‘Mark as Answer’ and Up-Vote the same.

    Friday, September 21, 2018 11:40 AM
    Owner