locked
The 'Idle Time-out (minutes)' property of the application pool's process model must be less than the 'Regular Time Interval (minutes)' property of the application pool's period restart. RRS feed

  • Question

  • User1982844092 posted

    Someone on our prod server had set the "Regular Time Interval" setting in the Recycling section to 0 on our app pool advanced properties.  Well, I tried that on our dev server.  And I get this error:

    The 'Idle Time-out (minutes)' property of the application pool's process model must be less than the 'Regular Time Interval (minutes)' property of the application pool's period restart.

    The Idle Time-out value in the Process Model section has a value of 20, just like our prod server.  So what gives?  How were we able to do the same thing in production but not on this attempt here?  Is there a special value you need to specify to force a zero?

    Thursday, August 13, 2009 11:35 AM

Answers

  • User511787461 posted

    This is a bug in the IIS UI - you will have to set it using some other method (appcmd, scripting, powershell, directly editing configuration etc).

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, August 13, 2009 8:47 PM
  • User744767459 posted

    Hi,

    Below is an appcmd command sample:

    appcmd.exe set config  -section:system.applicationHost/applicationPools /[name='DefaultAppPool'].recycling.periodicRestart.time:"00:00:00"  /commit:apphost

    Also, you can uncheck the Regular time intervals(in minutes) option in the dialog box of Edit Application Pool Recycling Settings to achieve this.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, August 18, 2009 5:22 AM

All replies

  • User511787461 posted

    This is a bug in the IIS UI - you will have to set it using some other method (appcmd, scripting, powershell, directly editing configuration etc).

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, August 13, 2009 8:47 PM
  • User744767459 posted

    Hi,

    Below is an appcmd command sample:

    appcmd.exe set config  -section:system.applicationHost/applicationPools /[name='DefaultAppPool'].recycling.periodicRestart.time:"00:00:00"  /commit:apphost

    Also, you can uncheck the Regular time intervals(in minutes) option in the dialog box of Edit Application Pool Recycling Settings to achieve this.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, August 18, 2009 5:22 AM