none
Unable to install WCF Adapter component in Biztalk Server 2010 RRS feed

  • Question

  • The information below between * from the two installation help fields in Biztalk Server 2010 installation.

    **************************************************************

    At least one of the prerequisites for this feature is not installed or
    met.

    Windows Communication Foundation Administration Tools

    **************************************************************

    At least one of the prerequisites for this feature is not installed or
    met.

    Selecting the Windows Communication Foundation Adapter component
    installs the necessary software that enables Microsoft BizTalk Server 2010 to
    integrate with Windows Communication Foundation.For more information on this
    component, click Help.

    *******************************************************************

    I'm just getting this **** installation guide information....doesn't tell me much. Other then something is missing I have done a server installation using the correct cab file. But still i can't install the WCF adpters (WCF-BasicHttp etc.) The funny thing is I have two environments, our test and our operation environment. And in our test environment I managed to install everything.

    Anyone got a clue about what could possibly be missing?



    • Edited by DasKarlmats Wednesday, February 27, 2013 7:04 AM Added further information.
    Tuesday, February 26, 2013 2:51 PM

Answers

  • I solved it myselfe, it turned out the .net framework 3.5.1 hadn't been activated in our operational environment. After installing it from the Server Manager -> Features -> add feature. It worked like a charm.
    • Marked as answer by DasKarlmats Wednesday, February 27, 2013 7:35 AM
    Wednesday, February 27, 2013 7:35 AM

All replies

  • do you want to install wcf-sql adapter .?

    is it 64 or 32 bit OS.?

    Regards

    Mohit

    Tuesday, February 26, 2013 3:15 PM
  • Show you more information about your problem, please. 

    Molly,
    Please Mark as the Answer, if this answers your question. Please vote as helpful, if this post is helpful.

    Wednesday, February 27, 2013 6:36 AM
  • No, just the basic WCF adapters. Like WCF-BacisHttp adapter. The ones that should be included in the first installation. The WCF adapter pack is of no use to me at the moment.
    Wednesday, February 27, 2013 6:41 AM
  • The server equipped with Windows Server 2008 r2 64-bit. 
    Wednesday, February 27, 2013 6:43 AM
  • I solved it myselfe, it turned out the .net framework 3.5.1 hadn't been activated in our operational environment. After installing it from the Server Manager -> Features -> add feature. It worked like a charm.
    • Marked as answer by DasKarlmats Wednesday, February 27, 2013 7:35 AM
    Wednesday, February 27, 2013 7:35 AM
  • Molly, I didn't have any more information at the moment. This was the most anoying thing about this issue. I couldn't find any information about why or specific needs to install the WCF adapters. But after thinking for around a day I came to think about the framework since the WCF is depending on it. And i noticed that in the installation guide the 4.0 and 3.5 version was mentioned. And in my environment i could only find 4.0 under installed programes. So then I downloaded the 3.5 and when trying to install it manually i stumbeled across the guide about how to install it in Windows Server 2008 R2.

    Wednesday, February 27, 2013 8:56 AM
  • Oh, I see.  

    Thanks for sharing your solution. :) 


    Molly,
    Please Mark as the Answer, if this answers your question. Please vote as helpful, if this post is helpful.

    Wednesday, February 27, 2013 9:34 AM