locked
The type or namespace name xxxx could not be found (are you missing a using directive or an assembly reference?) RRS feed

  • Question

  • User-1307167327 posted
    The type or namespace name xxxx could not be found (are you missing a using directive or an assembly reference?)
    i searched so many websites i cant get clear answer. . provide some suggestion
    Monday, June 17, 2013 6:06 AM

Answers

  • User-1373950060 posted

    Hi,

    To solve your problem please check following points:

    1. You don't have a class or namespace called "XXXX" in your project.

    2. The class exists, but the assembly (project) it was created in isn't set as a reference to the project you're trying to call it from.

    3. You do have this class, you are referencing the assembly, but your "using" statement including the namespace where this type appears isn't listed in your file anywhere.

    Hope that's helpful.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, June 17, 2013 11:09 PM

All replies

  • User197322208 posted

    The type or namespace name xxxx could not be found

    search for xxx in your code. What it is and where did you declare it?

    Monday, June 17, 2013 6:08 AM
  • User-1373950060 posted

    Hi,

    To solve your problem please check following points:

    1. You don't have a class or namespace called "XXXX" in your project.

    2. The class exists, but the assembly (project) it was created in isn't set as a reference to the project you're trying to call it from.

    3. You do have this class, you are referencing the assembly, but your "using" statement including the namespace where this type appears isn't listed in your file anywhere.

    Hope that's helpful.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, June 17, 2013 11:09 PM