none
SharePoint Enabled Hosts problem for BTS sharepoint adapter 2010 RRS feed

  • Question

  • We have a BizTalk 2010 connecting to Sharepoint Foundation 2010, each is on their own server. The BizTalk Sharepoint adapter is installad and configured at Sharepoint server. Everything looks good, the Sharepoint adapter web service is accessible. I am using a domain account which has the admin right on both servers and is also the biztalk admin and Sharepoint site full control.

    I am keep getting the error 'The Windows SharePoint Services adapter runtime does not have permissions to invoke the adapter Web service. In order to fix this issue, you have to add the Contoso\administrator Windows account to the "SharePoint Enabled Hosts" Windows group on the Windows SharePoint Services machine'. The problem is this was already done.

    I am really frustrated with this error, spent the entire morning without progress. I am not really sure where the failure point is, in sharepoint or adapter. How can I turn on the adapter tracing and see whats going on there.

    Thanks so much in advance


    https://ninithepug.wordpress.com/
    Wednesday, March 23, 2011 6:31 PM

Answers

  • Hey,

    Have you restarted the Host Instances ever after the permissions for the BizTalk Account was given? The permissions will take effect only after restarting the instances.

    Also make sure that the account specified in the Handler of the Sharepoint Adapter(Host Instance used by the sharepoint port) is the one you are granting rights.

    Thanks.

    Please mark this as answered if it helps.


    Sriram N http://srirambiztalks.wordpress.com/
    Wednesday, March 23, 2011 10:49 PM