locked
Change the master page for Blog site. RRS feed

  • Question

  • Hi ,

     I have created a blog. when i try to change the master page it was not getting updated.

    and i have to change the system master page to get the look and feel.

    But it is affecting all the system pages.

    Is there any workaround for this?

    Thanks,

    Sudan

    Wednesday, August 1, 2012 11:02 AM

Answers

  • In the Central Admin .Application general settings-->Application Master Page settings  you can set the values to No  such that the system pages will not inherit the custom Master pages .
    • Edited by Thilosh V N Wednesday, August 1, 2012 11:22 AM
    • Marked as answer by Pengyu Zhao Thursday, August 9, 2012 2:22 AM
    Wednesday, August 1, 2012 11:16 AM
  • Hi Sudan,

    If the blog is hosted on SharePoint Server (not just Foundation), then you can turn on Publishing features. This would allow you to easily set the default master page for your blog. The catch is that blog pages, by default, use the "default" or "system" master page, meaning that if you set the default master page for the blog then the site actions pages for the blog site will also use the same master page.

    If you are on Foundation, then you can open you blog in SPD and go to the All Files->_catalogs->masterpage directory, right click you custom master page (after you add it of coarse), and set it as the default master page.

    Now if you want your blog pages to use a custom master page that the site actions pages do not use, then it is a little more tricky. You will need to open up the Blog list folder in SPD and edit the different aspx pages added by SharePoint. In the @Page decloration at the top of each file you will need to set the masterpagefile="custom.master".

    I hope this helps.


    Eric Overfield - PixelMill - blog.pixelmill.com/ericoverfield - @EricOverfield

    • Marked as answer by Pengyu Zhao Thursday, August 9, 2012 2:22 AM
    Wednesday, August 1, 2012 5:26 PM

All replies

  • In the Central Admin .Application general settings-->Application Master Page settings  you can set the values to No  such that the system pages will not inherit the custom Master pages .
    • Edited by Thilosh V N Wednesday, August 1, 2012 11:22 AM
    • Marked as answer by Pengyu Zhao Thursday, August 9, 2012 2:22 AM
    Wednesday, August 1, 2012 11:16 AM
  • Hi Sudan,

    If the blog is hosted on SharePoint Server (not just Foundation), then you can turn on Publishing features. This would allow you to easily set the default master page for your blog. The catch is that blog pages, by default, use the "default" or "system" master page, meaning that if you set the default master page for the blog then the site actions pages for the blog site will also use the same master page.

    If you are on Foundation, then you can open you blog in SPD and go to the All Files->_catalogs->masterpage directory, right click you custom master page (after you add it of coarse), and set it as the default master page.

    Now if you want your blog pages to use a custom master page that the site actions pages do not use, then it is a little more tricky. You will need to open up the Blog list folder in SPD and edit the different aspx pages added by SharePoint. In the @Page decloration at the top of each file you will need to set the masterpagefile="custom.master".

    I hope this helps.


    Eric Overfield - PixelMill - blog.pixelmill.com/ericoverfield - @EricOverfield

    • Marked as answer by Pengyu Zhao Thursday, August 9, 2012 2:22 AM
    Wednesday, August 1, 2012 5:26 PM
  • Hi,

    I wanted to apply master page for blog site.

    if we set the custom master page then it gets applied to system pages as well.

    is ther any better way to brand blog site?

    Thanks,

    Sudan

    • Merged by Qiao Wei Friday, August 17, 2012 1:48 AM similar issue
    Friday, August 3, 2012 4:49 PM
  • I believe that you have already started another thread, which is getting responses here:

    http://social.msdn.microsoft.com/Forums/en-US/sharepoint2010general/thread/d17c8570-952e-49a2-a493-7415600ea8a7

    Please avoid posting same question at multiple places.


    Thanks & Regards,
    Kamlesh | Blog | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.


    • Edited by KSDN Friday, August 3, 2012 5:28 PM
    Friday, August 3, 2012 5:27 PM