none
Team explore istallation error fatal error RRS feed

  • Question

  • When I try to install visual studios I get a team explorer fatal error because some other packages did not install correctly such as (NugGet, visual studio connected services, ect) what I try to install them manually an d I go to the log it says

    1/23/2016 4:01:41 PM - Microsoft VSIX Installer
    1/23/2016 4:01:41 PM - -------------------------------------------
    1/23/2016 4:01:42 PM - Initializing Install...
    1/23/2016 4:01:42 PM - Extension Details...
    1/23/2016 4:01:42 PM -  Identifier         : NuGet.0d421874-a3b2-4f67-b53a-ecfce878063b
    1/23/2016 4:01:42 PM -  Name               : NuGet Package Manager for Visual Studio 2015
    1/23/2016 4:01:42 PM -  Author             : Microsoft Corporation
    1/23/2016 4:01:42 PM -  Version            : 3.3.0.167
    1/23/2016 4:01:42 PM -  Description        : A collection of tools to automate the process of downloading, installing, upgrading, configuring, and removing packages from a VS Project.
    1/23/2016 4:01:42 PM -  Locale             : en-US
    1/23/2016 4:01:42 PM -  MoreInfoURL        :
    1/23/2016 4:01:42 PM -  InstalledByMSI     : False
    1/23/2016 4:01:42 PM -  SupportedFrameworkVersionRange : [0.0,2147483647.2147483647]
    1/23/2016 4:01:42 PM -
    1/23/2016 4:01:43 PM -  SignatureState     : ValidSignature
    1/23/2016 4:01:43 PM -  SignedBy           : Microsoft Corporation
    1/23/2016 4:01:43 PM -  Certificate Info   :
    1/23/2016 4:01:43 PM -   -------------------------------------------------------
    1/23/2016 4:01:43 PM -   [Subject]       : CN=Microsoft Corporation, OU=MOPR, OU=OPC, O=Microsoft Corporation, L=Redmond, S=Washington, C=US
    1/23/2016 4:01:43 PM -   [Issuer]        : CN=Microsoft Code Signing PCA 2010, O=Microsoft Corporation, L=Redmond, S=Washington, C=US
    1/23/2016 4:01:43 PM -   [Serial Number] : 33000000A81581DB462EBDD9480000000000A8
    1/23/2016 4:01:43 PM -   [Not Before]    : 3/4/2015 6:42:40 PM
    1/23/2016 4:01:43 PM -   [Not After]     : 6/4/2016 7:42:40 PM
    1/23/2016 4:01:43 PM -   [Thumbprint]    : EFCF3B47C17854AB6E4C63821DE31A59B24D62B2
    1/23/2016 4:01:43 PM -
    1/23/2016 4:01:43 PM -  Supported Products :
    1/23/2016 4:01:43 PM -   Microsoft.VisualStudio.Pro
    1/23/2016 4:01:43 PM -    Version : [14.0,)
    1/23/2016 4:01:43 PM -   Microsoft.VisualStudio.Community
    1/23/2016 4:01:43 PM -    Version : [14.0,)
    1/23/2016 4:01:43 PM -   Microsoft.VisualStudio.VWDExpress
    1/23/2016 4:01:43 PM -    Version : [14.0,)
    1/23/2016 4:01:43 PM -   Microsoft.VisualStudio.VPDExpress
    1/23/2016 4:01:43 PM -    Version : [14.0,)
    1/23/2016 4:01:43 PM -   Microsoft.VisualStudio.VSWinExpress
    1/23/2016 4:01:43 PM -    Version : [14.0,)
    1/23/2016 4:01:43 PM -   Microsoft.VisualStudio.VSWinDesktopExpress
    1/23/2016 4:01:43 PM -    Version : [14.0,)
    1/23/2016 4:01:43 PM -
    1/23/2016 4:01:43 PM -  References         :
    1/23/2016 4:01:43 PM - System.MissingMethodException: Method not found: 'System.Collections.Generic.IEnumerable`1<System.Security.Cryptography.X509Certificates.X509ChainStatus> Microsoft.VisualStudio.ExtensionManager.IInstallableExtension.get_InvalidCertificateInformation()'.
       at VSIXInstaller.App.LogSignatureDetails(IExtension extension)
       at VSIXInstaller.App.LogExtensionDetails(IExtension extension)
       at VSIXInstaller.App.InitializeInstall(Boolean isRepairSupported)
       at VSIXInstaller.App.InitializeInstall()
       at System.Threading.Tasks.Task.InnerInvoke()
       at System.Threading.Tasks.Task.Execute()

    Please Help!

    Thanks!


    • Edited by David1776 Saturday, January 23, 2016 9:06 PM
    Saturday, January 23, 2016 9:05 PM

Answers

  • Hi David1776,

    Thank you for posting in MSDN forum.

    What’s your VS version and OS, please help me to confirm and thanks.

    From your description, I found a similar issue with some solutions that maybe helpful for you, please take a look at here:

    http://stackoverflow.com/questions/33855177/multiple-errors-installing-visual-studio-2015-community-edition/34008086

    Some effective workarounds from the above link:

    TimVdG: You can check if you have this problem by looking at the vcruntime140.dll file size. Search your windows folder for "vcruntime140" you should see 4 files (64 and 32 bit in both release & debug versions). If any files have the same size, you need to run a repair on the redistributable. On my system the 32 bit dll is 83,3KB, the 64 bit is 86,6KB ( release versions )

    Björn Blissing: In my case it was msvcp140.dll that was installed as a 64bit version in the Windows/SysWOW64 folder. Just uninstalling the redistributables did not remove the file, so I had to delete it manually. Then I was able to install the x86 redistributables again, which installed a correct version of the dll file. And, voilà, the installation of VS2015 finished without errors

    AbuOmar: 1. go to control panel -> uninstall programs -> uninstall all Microsoft C++ ((year)) Redistributable 2. delete those files if they still exist manually: c:\windows\System32\vcruntime140.dll & c:\windows\SysWOW64\vcruntime140.dll 3. download and install: https://www.microsoft.com/en-us/download/details.aspx?id=48145

    If the above methods cannot fix this issue, I need your help to collect the VS installation log file to troubleshoot this issue,
    please use
    http://aka.ms/vscollect to gather the installation logs. After using it, you will find vslogs.cab under %temp% folder. Please upload the file to https://onedrive.live.com/ and share the link here, thanks a lot and looking forward your reply.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    Tuesday, January 26, 2016 8:52 AM
    Moderator