locked
Horrible rendering for metro style app in both VS and Blend design view when DPI is set higher than 100%

    General discussion

  • I get horrible rendering in design view on both VS and Blend when I set the display's DPI to more than 100%. Here are some comparative screenshots.

    With DPI (or text size) set to 100%.

    With DPI (or text size) set to 125%.

    My graphics card is a NVIDIA Quadro FX 880M, and drivers are the latest available at geforce.com (296.17).

    Saturday, March 24, 2012 8:50 AM

All replies

  • Hi,

    Thanks for reporting this. I tried this on my machine with our latest bits and it seems to work fine (however I have not tried it with the same graphics card as you mentioned). It would be great to know a few more details so that we can try to reproduce this in house.

    1. What language are you running?

    2. Is this only within the designer (i.e. does the app look correct at run time)?

    3. Is this only for Metro Style applications (i.e. does this work correctly for the WPF/SL designers?

    Thanks in advance!


    Jeetendra Kukreja, Microsoft Expression. This posting is provided "AS IS" with no warranties, and confers no rights.


    Saturday, March 24, 2012 5:58 PM
  • Hi,

    1. I'm running Win8 64 bits in English, with culture set to Spanish (Mexico).

    2. It only happens within the designer, the app looks fine once you run it.

    3. Here a discovery. The designer for WPF works just fine, but the Silverlight one present the same behavior described above.

    On a additional note, I just noticed that nvidia drivers just are not cool with Windows 8 and my card. Sometimes I get graphics artifacts when using metro apps, I did get the sad face of death (TM) twice because the drivers got nuts.

    I'll be here if you anything else, I'm glad to help. 

    Saturday, March 24, 2012 6:14 PM
  • Hi Miguel,

    Do you have your BIOS Display setting set to Optimus ? .


    Dev@Mic

    Saturday, March 24, 2012 8:15 PM
  • I don't have that option in my bios.
    Saturday, March 24, 2012 8:25 PM