none
Create PDF using DoCmd.Outputto method in legal size page RRS feed

  • Question

  • I am working in MS Access 2010. I am trying to convert a report to a PDF file.  I am using the following command "DoCmd.Outputto acOutputReport, Report Name, acFormatPDF, FileName".  The report I am using is formatted in legal page size.  When the PDF is created  using letter size pages and the buttom of each page is cut off.  I would like to find out why this is happening.

    Bob Gouveia
    Saturday, October 1, 2011 12:17 AM

Answers

  • Open the report in Design mode. Click Page Setup, go to the Page tab, and click the "Use Specific Printer" readio button. Click Printer. Select the Adobe PDF printer, then click Properties. Make sure Legal is the selected paper size. Click OK twice to get back to the page setup window. Make sure the paper Size field is Legal, and Source is Automatically Select.

    When I do this OutputTo --> PDF corretly uses the size (Legal) and orientation (Landscape) that I selected. Does this work for you?


    jmh
    Monday, October 10, 2011 2:19 PM

All replies

  • Open the report in Design mode. Click Page Setup, go to the Page tab, and click the "Use Specific Printer" readio button. Click Printer. Select the Adobe PDF printer, then click Properties. Make sure Legal is the selected paper size. Click OK twice to get back to the page setup window. Make sure the paper Size field is Legal, and Source is Automatically Select.

    When I do this OutputTo --> PDF corretly uses the size (Legal) and orientation (Landscape) that I selected. Does this work for you?


    jmh
    Monday, October 10, 2011 2:19 PM
  • I'm confused by this.  We can use acFormatPDF even if we don't have Adobe PDF printer installed.  I can't change adobe pdf converter's settings because I don't have that.  I'm using the built-in functionality of 2010.  

    Wednesday, January 14, 2015 10:32 PM
  • I agree - this is the wrong answer.

    Try this: in design view, on the ribbon thing click "Report Design Tools" then "Page Setup" and choose Landscape. Then save the report. Worked for me.

    • Edited by piersg Thursday, April 30, 2015 10:23 AM
    Thursday, April 30, 2015 10:16 AM