none
How to get to project properties/build settings to allow /unsafe compiling?

    Question

  • Everywhere I go I see people simply saying "right click project -> properties -> build -> check allow unsafe".. When I right click my project and go to properties there's nothing resembling what people describe as the property window.

    I'm using VS 2015 and all that happens when I right click -> properties my project it shows a little window at the bottom right corner with rows labelled

    (name)
    Active config
    description
    etc. etc.

    There're no tabs that I can switch to and find build settings to allow for compiling with unsafe code. I would greatly appreciate any suggestions or solutions.

    Tuesday, April 05, 2016 11:59 PM

Answers

  • Hi,

    Thanks for you post.

    Could you please tell me what's your project type?

    I did a test in my side using VS2015 and I can find this option for C# project, but I can't find it for VB or C++ project.

    So I suppose this option is only available for some C# projects

    Best Regards,

    Lake Xiao 

    Wednesday, April 06, 2016 5:48 AM
    Moderator

All replies

  • Hi,

    Thanks for you post.

    Could you please tell me what's your project type?

    I did a test in my side using VS2015 and I can find this option for C# project, but I can't find it for VB or C++ project.

    So I suppose this option is only available for some C# projects

    Best Regards,

    Lake Xiao 

    Wednesday, April 06, 2016 5:48 AM
    Moderator
  • Thank you for the quick reply.

    My project is a C# script that I'm trying to compile for Unity Game Engine. I open the script on VS2015 through the Unity Engine, which opens it on VS2015 when I double-click.

    After some digging, I think VS2015 is reading my script as a solution instead of a project for some bizarre reason. Every item in the solution explorer only opens solution properties instead of project properties.

    I also tried to open the C# script straight through VS2015 and open properties through there... sadly no luck. This is very strange.

    I suppose one alternative is to simply create a new project with VS and copy all my code to the new script, but I feel I shouldn't have to do that...

    EDIT: Figured it out, just created an smcs.rsp file and imported it into my assets folder with "-unsafe" written in it.

    I appreciate your assistance regardless

    Wednesday, April 06, 2016 6:17 PM