locked
I get an error acces denied sign in as different user when I want to log on my web application RRS feed

  • Question

  • hello,

    I just create web application for training aim(I am studying 70-667) with web appication name bob.john.local.              

    I have 2008r2 server on which I installed sharepoint 2010.I promote my server as domain controller and gave him domain name john.local ,  so I don't have any public domain name or IP address.  I create also for my web application(bob.john.local) an A record in DNS as the study book telling me.

    now when I want to log on my web application I get an error telling me.

    ERROR: access denied

    current user

    you are currently signed in as:david0\david     (david0 is  my netbios name and david is my user account).

    sign in as different user

    go back to site.      

    david which is my user account I added in manage account before I create the web application(bob.john.local) also I made david member of administrator and farm administrator but I don't understand why I still I can not log on my web application.

    any suggestion.  very short answer wil be enough.

    thanks

    johan


    h.david

    Saturday, May 19, 2012 6:44 PM

Answers

  • Hi,

    Just to double check a few things.

    • Did you create a Site Collection in the web application that you are trying to access?
    • If you create the Site Collection, did you check if you are the site collection administrator?
    • Did you disable loop back check?
    • You must be having a farm account and a setup account. Did you try to access with any of these two accounts?

    Thanks, Soumya | MCITP, SharePoint 2010

    Saturday, May 19, 2012 10:52 PM
  • OK, so let take a step back and retry this. Please create the web application on port 80. In fact, besides CA, create all web applications on port 80 unless there is a pressing reason not to do so. If you do multiple web applications, make them differ via host headers (if you are doing this for home lab, you can have an entry made in the local host drive.

    Once this is done, install fiddler or httpWatch basic (I prefer the second one), and load up the application and recreate the problem. And have httpWatch running to track the httpTrace. Quite possibly this will give you additional clues.

    In fact if all these are confusing, one simple test to do right in the beginning may be not to involve SharePoint at all. Just create a plain vanilla IIS website at port 80 and assign bob.john.local to it as host header and check if you access it. I believe if this test is successful, you will be later on able to access the SharePoint site as well.

    So to summarize:

    Delete your SharePoint web application

    Recreate IIS web application and test

    If it does not work, troubleshoot with httpWatch basic

    If that goes well, delete IIS web application and recreate SharePoint web application

    If it does not work, troubleshoot with httpWatch basic


    Thanks, Soumya | MCITP, SharePoint 2010

    Sunday, May 20, 2012 4:02 PM
  • I guess you may have to check with the AAM settings in CA for this

    Please do check

    1) Hostheader created in DNS should be pointng towards the sharepoint box  to comfirm this you can do NSlookup for ip address as well as the Hostheader to ensure its gettng resolved

    2) Once we have the point 1 done  you can move to IIS manager on you sharepont box Find you virturl directory of the Site  > click on add bindings > click on add add the hostheader Port number 80 click on ok

    3) check with ALternate Access mapping on Sharepoint central administration .Make sure that the Hostheader Url is added to zones

    4) do Iisreset/noforce (If possible )and try to browse the site

    Note In case if you are having multiple prompts when you are browsing site on the server Make sure you have disable loopback follow Method 2 of Kb 896861

    hope so this helps

    Thanks

    Tuesday, May 22, 2012 7:28 AM

All replies

  • Hi,

    Just to double check a few things.

    • Did you create a Site Collection in the web application that you are trying to access?
    • If you create the Site Collection, did you check if you are the site collection administrator?
    • Did you disable loop back check?
    • You must be having a farm account and a setup account. Did you try to access with any of these two accounts?

    Thanks, Soumya | MCITP, SharePoint 2010

    Saturday, May 19, 2012 10:52 PM
  • hello,

    first thanks for your response,

    1-I created a site collection

    2- I have 2 administrators in site collection(farm administrator,domain administrator etc)

    3-I have made a disable loop back check(DWORD) key in registry and gave him a value 1.( I know this things from sbs2008 forum)

    4- I see I have a farm account but I don't know where to find  the setup account if I have one ,I searched in CA but I couldn't  find it.(I don't know in which section I can look for it).

    I tried also some other way ,in place of  entering bob.john.local  in URL  I entered  http://bob.john.local:950 (950 is the port number of my web application)and now I get another  type of error   http error 404.

    so now there is 2 situation when I enter only bob.john.local I get an error sign in with onother user name.   and when I enter bob.john.local:950 I get a http error 404.  I tried also from IIS manager to browse to my web application  so I get the same http 404 error.

    I searched in google for http 404 error and found that I have to go to IIS manager and on default web site right click on it and go to properties to make some changes ,but when I go to default web site in IIS manager and right click on it I don't see any properties option,strange.

    do you have any idea how to solve this problem.

    thanks

    johan


    h.david

    Sunday, May 20, 2012 10:11 AM
  • OK, so let take a step back and retry this. Please create the web application on port 80. In fact, besides CA, create all web applications on port 80 unless there is a pressing reason not to do so. If you do multiple web applications, make them differ via host headers (if you are doing this for home lab, you can have an entry made in the local host drive.

    Once this is done, install fiddler or httpWatch basic (I prefer the second one), and load up the application and recreate the problem. And have httpWatch running to track the httpTrace. Quite possibly this will give you additional clues.

    In fact if all these are confusing, one simple test to do right in the beginning may be not to involve SharePoint at all. Just create a plain vanilla IIS website at port 80 and assign bob.john.local to it as host header and check if you access it. I believe if this test is successful, you will be later on able to access the SharePoint site as well.

    So to summarize:

    Delete your SharePoint web application

    Recreate IIS web application and test

    If it does not work, troubleshoot with httpWatch basic

    If that goes well, delete IIS web application and recreate SharePoint web application

    If it does not work, troubleshoot with httpWatch basic


    Thanks, Soumya | MCITP, SharePoint 2010

    Sunday, May 20, 2012 4:02 PM
  • I guess you may have to check with the AAM settings in CA for this

    Please do check

    1) Hostheader created in DNS should be pointng towards the sharepoint box  to comfirm this you can do NSlookup for ip address as well as the Hostheader to ensure its gettng resolved

    2) Once we have the point 1 done  you can move to IIS manager on you sharepont box Find you virturl directory of the Site  > click on add bindings > click on add add the hostheader Port number 80 click on ok

    3) check with ALternate Access mapping on Sharepoint central administration .Make sure that the Hostheader Url is added to zones

    4) do Iisreset/noforce (If possible )and try to browse the site

    Note In case if you are having multiple prompts when you are browsing site on the server Make sure you have disable loopback follow Method 2 of Kb 896861

    hope so this helps

    Thanks

    Tuesday, May 22, 2012 7:28 AM