none
BTMan driver not loaded at start up in Windows Embedded Compact 7 RRS feed

  • Question

  • Hi,
    Bluettoth BTMan driver btman.dll is not getting loaded during boot up. Also, it is not hitting DllMain() entry function at all. Here is the log
    PB Debugger Loaded symbols for 'C:\WINCE700\RELEASE\RETAIL_CEBASE_WWE\WINCE\BTMAN.DLL'
    PB Debugger Loaded symbols for 'C:\WINCE700\RELEASE\RETAIL_CEBASE_WWE\WINCE\K.BTDRT.DLL'
    PB Debugger Unloaded symbols for 'C:\WINCE700\RELEASE\RETAIL_CEBASE_WWE\WINCE\K.BTDRT.DLL'
    PB Debugger Unloaded symbols for 'C:\WINCE700\RELEASE\RETAIL_CEBASE_WWE\WINCE\BTMAN.DLL'

    Registry settings reginit.ini:
    [HKEY_LOCAL_MACHINE\Drivers\BuiltIn\BTMan]
    "Dll"="BTMan.dll"
       "Prefix"="BMN"
       "Index"=dword:0
       "Order"=dword:10                    
       "Priority256"=dword:99  ;153
       "IClass"=multi_sz:"{A32942B7-920C-486b-B0E6-92A702A99B35}"
       "Script6450-NON-L" = "WL127x_2.0_BT_SP_2.38_C1.5_R3686400-M_PCM.bts"
       "Script6450-L-SERIES-ABGN" = "WL1271L1_BT_SP_1.5_3dBm_ABGN_M_PCM.bts"
       "Script6450-L-SERIES-BGN" = "WL1271L1_BT_SP_1.5_2dBm_BGN_M_PCM.bts"
       "Script6450-PLUG-IN" = "bluetooth_init_cc2560_2.44.bts"
       "DebugMask"=dword:0

    Driver entry is present in ce.bib:

    btman.dll       C:\WINCE700\release\retail_cebase_WWE\wince\btman.dll                  NK MODULE SHK

    WL127x_2.0_BT_SP_2.38_C1.5_R3686400-M_PCM.bts  C:\WINCE700\WL127x_2.0_BT_SP_2.38_C1.5_R3686400-M_PCM.bts  NK FILE SHK
    WL1271L1_BT_SP_1.5_3dBm_ABGN_M_PCM.bts  C:\WINCE700\WL1271L1_BT_SP_1.5_3dBm_ABGN_M_PCM.bts  NK FILE SHK
    WL1271L1_BT_SP_1.5_2dBm_BGN_M_PCM.bts  C:\WINCE700\WL1271L1_BT_SP_1.5_2dBm_BGN_M_PCM.bts  NK FILE SHK

    Missing anything..? please...

    Thanks,

    Sachin

    Thursday, May 23, 2013 3:44 PM

All replies