locked
Mutiple Endpoints: wsHttpBinding and NetTCP - The protocol 'net.tcp' is not supported. RRS feed

  • Question

  • User2043281626 posted

    Hello,

    I have a WCF; using .NET 4.0, which initially was only using wsHttpBinding and was working fine. I added a netTCP binding and endpoint I get the following message; "The protocol 'net.tcp' is not supported."

    If I comment out the netTCP endpoint the service runs no problem, so I am thinking there is something wrong in how I set my endpoint or VS is not setup to use TCP, maybe on HTTP when debugging. Can someone weigh in on this for me, please I need help. This should be a simple thing of adding the new endpoint, but I have been struggling with it for awhile now.

    Monday, July 29, 2013 10:54 AM

Answers

All replies

  • User-1662538993 posted

    Did you enable the protocol at iis level after configuring the service?

    If not then you should do that first and give it a try to run.

    Monday, July 29, 2013 11:39 AM
  • User2043281626 posted

    Sorry for my ignorance, but how do i do that? I may not have permission to do that too. But please give me the steps anyway.

    Monday, July 29, 2013 11:44 AM
  • User-1662538993 posted

    When you have hosted the service in iis just try to do follow:

    Right click on the service on your left side in iis and then Manage Application -> Advance Settings

    Once the pop up comes under Advanced behaviour you should have Enabled protocol.

    Check net.tcp is there or not, if not add it.

    Enabled Protocol: http,net.tcp

    Monday, July 29, 2013 11:52 AM
  • User2043281626 posted

    Sorry but I cannot do this on my local machine, I can only run it in VS. I don't have permissions to IIS for security reasons; some I perform that operation.

    Monday, July 29, 2013 12:07 PM
  • User2043281626 posted

    Let me mention again, that one of the constraints I have placed on me is that I can use Visual Studio to test this. Therefore, I can go to IIS like some of contributors have mentioned. I do appreciate the hel though!

    Is there is anyway I can address this issue beyond what I received in the previous replies?

    Monday, July 29, 2013 1:39 PM
  • User-1662538993 posted

    Check in your system processes that all the services are running related to net.tcp as well.

    For that you can go to Services by going to task manager and check there should be some services related to nettcp and check if those are running or not. if not then try to enable those and start running those.

    Monday, July 29, 2013 3:31 PM
  • User503812343 posted

    check below link for managing multiple enpoints for one service

    wcf service with multiple endpoints

    AS you said you had wsHttpBinding, I guess you have hosted your wcf service in IIS. If you have netNamedPipeBinding or netTcpBinding for your service and hosted in IIS you need to make some settings at IIS level and servives.

    this article will help you to make neccessary changes for netTcpBinding

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, July 30, 2013 11:03 AM