none
Editor Font does not match setting in Visual Studio 2019 RRS feed

  • Question

  • The font does not display correctly in VS 2019.   I had no problems in VS 2017.   I would like a bolder font to make it easier to see.   Am I missing something?   I am trying to use Fixedsys bold but the displayed test is very thin.


    Sunday, August 25, 2019 8:03 PM

All replies

  • Hi DMHitchner,

    Welcome to MSDN forum.

    For your requirement, you could choose the corresponding options of text that you want to set to bold in Display items list, by adding the “Bold” switch (Keyword, String, Number,…).

    For example, you could point to Keyword and select “Bold” to set the keyword of the codes to bold, point to User Types – Classes and selectBold” to set the types classes of the codes to bold.

    Hope this could help you.

    Best Regards,

    Tianyu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, August 26, 2019 5:25 AM
  • Thanks.  That helped some but so far I have been able to change all the text in the editor.  In VS2017 I only changed plain text and everything else used that as a template.
    Tuesday, August 27, 2019 1:03 AM
  • Hi DMHitchner,  

    Thanks for your feedback.   

    According to your description, I have tried to use VS 2019 and just choose "Plain Text" then checked "Bold". It also does not display correctly in my side. After that, I tried to use vs 2017, however, it doesn't work too. 

    If possible, could you please share us with more information about which kinds of projects do you create? Then I will help you to post this issue to production team.  

    Looking forward to hearing from you.  

    Best Regards,

    Tianyu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, August 27, 2019 8:50 AM
  • Hi friend,

    Any update for this issue?

    Since you have several VS in one machine, sometimes it may mess up the font settings cause they use the same file which store the info about fonts.

    Assuming you have both VS2017 and VS2019 in the machine. You can try:

    1. Close all vs instance and then clean the VS cache following this doc , for VS2019, version is 16.0. 

    You should delete all ComponentModelCache folders in 15.0_xxx and 16.0_xxx folders.

    2. Open all vs versions in your machine, go Tools=>Options=>Account=> uncheck the Synchronize settings across devices when signed in VS option. Close all vs instances and restart vs2019.

    (This option will affect your behavior of changing settings when you signed in the machine with an account also signed in another one)

    3.After restart VS2019, go Tools=>Import and Export settings=>Reset all settings=>No, just reset settings...

    After that, you can change size or mark it bold to make it work. And I suggest you use the default Font, since after my check the bold seems to not support or work for Fixedsys font.

    Also, since your original issue is to make the editor easier to see, I think you can simply change the scaling at lower left corner of the window to 115% or more then it's easier to see.

    Hope all above helps. Any feedback would be expected.

    Best Regards

    Lance


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, August 28, 2019 8:32 AM
  • Thanks for your responses.

    I have Visual Studio 2017 on my work system and 2019 on my home system.  On my work system Fixedsys Bold displays correctly and previously display correctly with 2017 on my home system.  I recently decided to reload my home system and begin using 2019 to get more familiar with it before we move to it at work.  VS 2019 is the first version that I have had an issue with getting the fonts to be easily readable.

    Increasing the display scale helps but it is more of a contrast things.  The thicker characters of the bold fonts makes it easier to see.

    Thursday, August 29, 2019 9:25 PM
  • Hi DMHitchner,

    Thank you for the reply.

    Please try to use other kinds of projects and check whether this issue persists, if so, you could post this issue to developer community via reporting this problem and then share us with the link of your post, so that I will go to vote for you and other members of forum who are interested in this issue will focus on it and vote for you. If you are inconvenient, feel free to contact us and we will help you to post this issue to developer community for better help.

    Thank you for your understanding.

    Best Regards,

    Tianyu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, August 30, 2019 9:38 AM
  • The problem is consistent with all projects.  I have reported to this to the developer community but no resolution so far.  I was hoping that someone else has encountered this on this forum.
    Monday, September 2, 2019 8:27 PM
  • Hi DMHitchner,

    Sorry for this inconvenience.

    If possible could you please share this issue’s link that you report in DC with us, then I will go to vote for you. Since engineers who support for Developer Community might need some time, please wait for the responses patiently.

    Thank you for your understanding.

    Best Regards,

    Tianyu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, September 3, 2019 6:11 AM
  • I finally found a font that renders properly.  It is a font I got several years ago named "Fixedsys Excelsior 2.00".  It is heavy enough that I do not need the bold setting.  Now the question is, why do other fonts not render like the sample in the settings?  While searching I have seen a lot of similar issues that Microsoft does not appear to feel that it is important enough of a problem to fix.
    • Edited by DMHitchner Saturday, September 7, 2019 3:10 PM
    Friday, September 6, 2019 9:46 PM
  • Hi friend,

    Thanks for your feedback.

    We are very glad to hear that you have found the properly font to look better and bold for you. Also about this issue I used to try to create a web project and set the font to bold by choosing ‘Plain Text’ and ‘Fixedsys’ to find out what exactly this ‘Plain Text’ affects the codes’ font and I found that actually just the “Plain Text” changed to bold, as you can see like the picture shows below.

    So i think the "Plain Text" might means just the plain text. But as you said above, you could work well in VS 2017, I also try to use VS 2017 but the same issue seems occurs to me not to you, this is strange and after I search online it seems that other people also encountered this issue when use VS 2017 and in the end I fail to reproduce this issue in my side. But change the options one by one can exactly work, Sorry for this inconvenience, we recommend that you could report this to product team and engineers there will try their best to fix this issue or add a new function(in vs -> Help -> Send Feedback -> Report a problem). Thank you for your understanding.

    Have a nice day.

    Best Regards,

    Tianyu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, September 9, 2019 9:42 AM