locked
LCS & Sharepoint integration RRS feed

  • Question


  •   I have install moss 2007 ,office 2007,lcs in one server.
     Then i config some  accounts  for  both lcs and sharepoint.
    I use one of them  to logon the sharepoint ,but i can't see the buddys of the account....
    why? I think it's feature of moss that show the status of lcs users.....
    Need i add some special webpart to achieve it?

      any suggestion?
    Wednesday, April 11, 2007 2:10 AM

Answers

  • Do you mean the Presense icon (bean)?

     

    This would show the LCS status of the user (online,  busy etc) when their name is shown,  i.e. against documents they have uploaded.

     

    Wednesday, April 11, 2007 11:46 PM

All replies

  • Do you mean the Presense icon (bean)?

     

    This would show the LCS status of the user (online,  busy etc) when their name is shown,  i.e. against documents they have uploaded.

     

    Wednesday, April 11, 2007 11:46 PM

  •   hi andrew woodward.
      Thanks for your reply
      I'm not sure the"presense icon"

      The "Presense icon" is a kind of web part?

     I can't find it.....
    Thursday, April 12, 2007 11:04 AM
  • The presence icon is the graphic that is displayed next to a user name.

     

    i.e.  if you upload a document to as documument library in the standard view you will see an icon next to your name that has a hover over dropdown menu to allow you to interact with that user.   The available options depend on the users status (online, busy etc).

    There is no additional web part to install.

     

    Andrew

    Thursday, April 12, 2007 11:07 AM
  • hi andrew 
    I  have upload a document in the document center ...but i didn't see the icon...

     can you show me some snapshot?
    Friday, April 13, 2007 12:13 PM
  • Hi,

     

    I have reproduced the problem in my dev environment,  single MOSS server with a seperate DC.

     

    - Each user has an email address, as shown in the sites and people.

    - Presence and Smart Tags are enabled in the Web Application General Settings (via central admin)

    - The Modified By column is showind Name (presense) for the person

     

    The column header has the presence icon next to the work Modified,  but no users have ther presence icon displayed when you hover over the user control.

     

    I have tested the client using the tip from sps 2003

     

    Put this code in an html file,  hover over and you should see an icon to the left of the text.  Note replace the email with your own or someone you have in MSN Messenger or Office Communicator

     

    Code Snippet

    <html>
    <head>
    <script language="JavaScript"><!--
    // Use Name.dll, installed by Office 2003 on the client PC:
    var nameCtrl = new ActiveXObject("Name.NameCtrl");
    //-->
    </script>
    </head>
    <body>
    <span
     onmouseover="nameCtrl.ShowOOUI('YOUREMAIL@TODO.COM',0,this.offsetLeft,this.offsetTop)"
     onmouseout="nameCtrl.HideOOUI()">
     Hover your mouse over this text to retrieve presence information
    </span>
    </body>
    </html>

     

     I cannot however get it to start working again,  I will continue to play with this and post my findings,  if anyone else has any clues please post them here.

     

    Andrew

    Friday, April 13, 2007 2:59 PM
  • Solved it.

     

    You need to add your site to your Trusted Sites for it to show up in IE7 using MOSS/WSS V3.

     

    Blog on this with images so you can see what it looks like.  http://www.21apps.com/2007/04/presence-icon-not-showing-in-moss.html

     

    Hope this solves it for you.

     

    Andrew

    Friday, April 13, 2007 5:16 PM
  • Even when a site is in trusted zone, still doesn't show. :(
    /bac
    Tuesday, January 20, 2009 11:17 AM