locked
Process with an ID #### is not running in visual studio professional 2019 RRS feed

  • Question

  • User87195929 posted

    Hi All

    when i run the code in vs in 2019

    I Am  getting error like 

    The program '[3148] iisexpress.exe' has exited with code

    Pls help me..

    Thursday, January 2, 2020 10:47 AM

All replies

  • User281315223 posted

    Without knowing more details about your scenario, it's going to be tough to troubleshoot exactly what is going on. Since the issue itself is related to IIS Express, a common route to troubleshoot this would be to try the following:

    • Close Visual Studio - This should stop IIS Express from running assuming your application is running locally.
    • Navigate to the Solution Folder and Delete the `.vs` Directory - This directory contains Visual Studio specific information that could be causing your issue. Visual Studio will handle regenerating the directory when you re-open your application.
    • Restart Visual Studio 
    • Rerun Your Application

    Thursday, January 2, 2020 8:01 PM
  • User1535942433 posted

    Hi siddangoud,

    I have three solutions.I suggest you should:

    1.Check your solution folder for a hidden ".vs" folder with a "config" sub-folder.If  that folder exists,you need to rename it.

    2.Open your project properties and in the Web tab, change the port in Project Url and then retry again.

    3.If your machine is 64bit, please go to Tools-> options -> projects and solutions:

    For example:

    https://i.stack.imgur.com/XbOxF.png

    More details ,you could refer to below article:

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/9cbe05df-36df-4005-857f-d08ac82492b3/the-program-14400-iisexpressexe-has-exited-with-code-0-0x0?forum=visualstudiogeneral

    Best regards,

    Yijing Sun

    Friday, January 3, 2020 9:35 AM
  • User87195929 posted

    Hi, sir

    thanks for the reply,

    I tried the solution, but it does not work for me,

    please give an alternate solution,

    Thanks and Regards

    siddur

    Friday, January 3, 2020 10:38 AM
  • User753101303 posted

    Hi,

    And it doesn't show an actual error code as part of the message ? This is an ASP.NET 4.x or an ASP.NET Core app ?

    Friday, January 3, 2020 12:42 PM