none
Engine error ...Root Node Wrong ...Missing or Invalid Transaction Set ....For 856 only RRS feed

  • Question

  •  

    Hello !

    Please look at the root node error..... i dont know where the engine is throwing this error from when this root node no where seems to exist....it is 00400 instead of 00401....

    All my schemas work except 856...I have not done any modification to the schema at all ....and I am not using it more than once any where ...

     

     

    Error: 1 (Miscellaneous error)
     6: Missing or invalid or duplicate Transaction set identifier 'http://schemas.microsoft.com/BizTalk/EDI/X12/2006#X12_00400_856

     

    Thursday, May 27, 2010 6:50 AM

Answers

  •  

    First for the schema identified as :'http://schemas.microsoft.com/BizTalk/EDI/X12/2006#X12_00400_856' check that the namespace in your schema is http://schemas.microsoft.com/BizTalk/EDI/X12/2006 and also root node  is X12_00400_856. If your root node in the schema is X12_00401_856 then check the GS8 has the appropriate version number i.e. 00401

    Secondly for wild card schema, it might be due to the schema is not found or the party is not found. Check that you are getting the party name in the context then it should be due to the first issue that you are seeing wild card schema.

    Nikhil

    Thursday, May 27, 2010 9:41 AM
  • Hi,

    The problem is with Transaction set Identifier. You need to verify the EDI version, either your application accepts 00400 and you send a different version or you pass 00400 while your application accepts some other version.

    Go to the deployed EDI schema and check for the version and then check the ISA segment and GS segment of your EDI X12 message.

    If possible please share the EDI 997 or error displayed in the eventvwr.

    Regards,


    Vishnu
    Thursday, May 27, 2010 11:33 AM

All replies

  • From the error message what I can say is that it is not error related to the root node. It is related to transaction set control number. Just check the party with which you are resolving this message is not having Check for Duplicate ST2 in the X12 interchange processing properties under Party as interchange sender.

    Nikhil

    Thursday, May 27, 2010 7:18 AM
  •  

     

    Hello !

     

     I don have that checked at all ..Also for other docs the process runs fine .but only with 856 it giving this error ...the validation at design time and run time both ....

     

     

    Thanks

    Thursday, May 27, 2010 8:33 AM
  •  

    Also The schema is deployed properly .......Another in the suspended msg the message type is of wildcardschema ...that means not able to find 856 schema ....

    I have deployed it correctly with the shipped target namespace and root node ....there is only one instance of it as well

     

     

    Thanks

    Thursday, May 27, 2010 8:44 AM
  •  

    First for the schema identified as :'http://schemas.microsoft.com/BizTalk/EDI/X12/2006#X12_00400_856' check that the namespace in your schema is http://schemas.microsoft.com/BizTalk/EDI/X12/2006 and also root node  is X12_00400_856. If your root node in the schema is X12_00401_856 then check the GS8 has the appropriate version number i.e. 00401

    Secondly for wild card schema, it might be due to the schema is not found or the party is not found. Check that you are getting the party name in the context then it should be due to the first issue that you are seeing wild card schema.

    Nikhil

    Thursday, May 27, 2010 9:41 AM
  • Hi,

    The problem is with Transaction set Identifier. You need to verify the EDI version, either your application accepts 00400 and you send a different version or you pass 00400 while your application accepts some other version.

    Go to the deployed EDI schema and check for the version and then check the ISA segment and GS segment of your EDI X12 message.

    If possible please share the EDI 997 or error displayed in the eventvwr.

    Regards,


    Vishnu
    Thursday, May 27, 2010 11:33 AM
  • I got similar error.

    Error  was resolved when I changed Party -> Incoming(Recvside) party-> Transaction Set Settings-> Local host settings -> Target namespace to correct value

    Wednesday, April 19, 2017 7:21 PM