locked
Internal server error - no further details RRS feed

  • Question

  • Have a pipeline that was working, doing several copies from premise SQL, to ADLS, to ADW. This was all working fine. I had attempted to make a few changes (added git repo, added parameters to datasets and pipeline). Then attempting to run or debug always results in 500 internal server error, with details: null and error null. There is no info available anywhere on this. I reverted back to the last commit where it worked, and still getting the error. Any idea on what could be wrong, or how to find additional info on the error?

    {"code":"InternalServerError","message":"InternalServerError executing request","target":"pipeline/My-Pipeline/runid/1eaa37fb-6aad-4ca2-9595-73e020d5722a","details":null,"error":null}


    vtcoder

    Thursday, July 11, 2019 3:09 AM

All replies

  • Hi there,

    I am working internally with the team to find out more details. Meanwhile, can you please share more details about the changes that you made that led to the error. Also, if possible can you please attach screenshots that might help us diagnose the problem?

    Thursday, July 11, 2019 10:47 AM
  • I had started the data factory without a git repo. I had published in that mode and it was all working. I then added a git repo and switched to that mode for the data factory.

    I also started to add parameters to ADLS datasets for the path. And then I added a pipeline parameter to pass the value to each dataset param. I had not gotten the parameters working yet, and then I started getting this error.

    I can't say for sure if the error is related to either of the above changes or not. However, I can't even use an older commit that used to work. All attempts to debug or trigger the pipeline now result in this same error.

     I'll try to get some screenshots when I'm able to retest it.

    I should also note - I get the same error now even when I switch from git to data factory mode.


    vtcoder


    • Edited by vtcoder Friday, July 12, 2019 2:06 AM Additional details
    Friday, July 12, 2019 1:54 AM

  • vtcoder

    Friday, July 12, 2019 2:02 AM
  • So I was able to finally get it to run by removing all parameters and switching to master branch and publishing from there.

    I was able to find some details on the issue with the parameters. I had the following which causes an error (no wildcard in sink path):

    concat(@dataset().customer_directory, "/myTableDirectory")

    I changed it to:

    @{dataset().customer_directory}/myTableDirectory

    And it works.

    These may be unrelated errors (the parameter issue, and the 500 internal server error). It seems like the 500 may have been related to trying to use a branch other than the collaboration branch (master)?

    Any additional details on what actually caused the error would be appreciated though.

    Thanks


    vtcoder

    Friday, July 12, 2019 2:48 AM
  • Hi there,

    Glad that your issue was resolved. Yes, the first expression is incorrect. The second one is correct. You could modify the first one to : 
    @concat(dataset().customer_directory, "/myTableDirectory")

    and it will work.
    Hope this helps.

    Monday, July 15, 2019 6:03 AM