none
[Solved]SDK 1.8 Constantly fails to install RRS feed

  • Question

  • Yesterday when updating from the 1.7 SDK to 1.8 I ran into some issues, solved the issues and then made some fatal mistakes. I had plugged my Kinect into the back of my PC and mistakenly plugged it into one of my USB 3.0 ports after installing the 1.8 SDK, well for some reason it detected it and installed the drivers properly but none of the tools would detect my Kinect nor would Skype detect the Kinect Cam's video feed using a third party script. So I closed down everything, uninstalled the SDK and the packages linked to it and reinstalled it, forgetting to unplug my Kinect, this caused my USB 3.0 driver to crash and blue screen my PC. Upon turning it back on I uninstalled the SDK components that did get installed and tried again, this time with my Kinect unplugged. Now the SDK always encounters an error on the driver installation portion of the SDK setup. I've tried everything, completely gotten rid of all traces of anything related to my Kinect in RegEdit, uninstalled all drivers related to it, everything. Nothing has worked, I've spent about nine hours in total diagnosing and debugging what the cause could be and the setup log doesn't seem to be of much help either but I can post it, the main error reports some kind of problem accessing the .inf it unpacks at: "C:\Windows\System32\DriverStore\FileRepository". That made me think it was a privilege issue but my account is the one and only acount and it's Admin status and this wasn't an issue before the blue screen.

    Setup Log: http://pastebin.com/1G02jyTx

    EDIT: Running Windows 7 Pro x64

    EDIT: I've tracked down the issue but I can't seem to solve it for the life of me. On this piece of the log file:

    "DIFXAPP: INFO:   ENTER:  DriverPackageInstallW

    DIFXAPP: WARNING:DRIVER_PACKAGE_LEGACY_MODE flag set but not supported on Plug and Play driver on VISTA. Flag will be ignored.
    DIFXAPP: INFO:   Installing INF file 'C:\Program Files\Microsoft Kinect Drivers\Drivers\Camera\kinectcamera.inf' (Plug and Play).
    DIFXAPP: INFO:   Could not open file C:\Windows\System32\DriverStore\FileRepository\kinectcamera.inf_amd64_neutral_f56ece27bcf1af86\kinectcamera.inf. (Error code 0x3: The system cannot find the path specified.)

    DIFXAPP: ERROR:  PnP Install failed. (Error code 0x3EE: The volume for a file has been externally altered so that the opened file is no longer valid.)"

    It shows that kinectcamera.inf can't be installed into the FileRepository folder for some reason, I've given that folder Everyone permissions just in case, deleted it so that the installer would rebuild it but nothing, it will not install the inf in there. If I install SDK 1.5 it puts the files in there no problem even if it has strict permissions and if I install SDK 1.8 over 1.5 it deletes everything in the FileRepository folder and fails to install the inf again. I'm really stumped.

    EDIT: I can fool the 1.8SDK into installing the drivers without a hitch by using the kinectcamera.inf from the 1.5SDK in the FileRepository folder then swap it out with the one from the Microsoft Kinect Drivers folder in Program Files, when I plug in my Kinect everything is good until it reaches the camera where it instantly fails prompting: "Can't replace file where one already exists." in Device Manager when I try to force install it. So I've gotten somewhere, but not very far. :/

    EDIT: 16 hours of intense debugging and hard work and I finally fixed it. Since this is a fairly common issue and no one else seems to have a fix I guess I'll do a run down of the steps I took.

    Firstly, make sure the SDK is uninstalled and your Kinect is disconnected, I also deleted all traces of the Kinect as a device in RegEdit though I'm sure this part doesn't really matter, but just in case, I'm mentioning it. Deleted all folders and drivers related to it under Program Files, Windows and System32, specifically there's kinectcamera.sys in: "System32\drivers" that needs to be gotten rid of and is left over from the drivers failing to install. Secondly, you'll need SDK 1.5, install it and grab the kinectcamera.inf from: "Program Files\Microsoft Kinect Drivers\Drivers\Camera" and place it somewhere safe for now. Find: "C:\Windows\System32\DriverStore\FileRepository\kinectcamera.inf_amd64_neutral_f56ece27bcf1af86" (If it doesn't exist, make it.) and place the kinectcamera.inf we got from the 1.5SDK in there. Uninstall SDK1.5 and install SDK1.8, it should install successfully, check that same FileRepository folder and make sure you have: kinect.cat, kinectcamera.inf, kinectcamera.sys and WdfCoInstaller01009.dll in there, if not, go to: "C:\Program Files\Microsoft Kinect Drivers\Drivers\Camera and copy everything from there into your kinectcamera.inf FileRepository folder. Great, now uninstall SDK1.8 and all of it's components including Microsoft Speech Server (x86) and (x64) and then go back to: "C:\Windows\System32\drivers" and delete kinectcamera.sys if it's there and check: "C:\Windows\System32\DriverStore\FileRepository" for it's Kinect drivers folders, if they're all gone, SDK1.8 should install successfully. If it does install successfully, make sure under Device Manager that all parts of your Kinect have their drivers installed, they may not show up with a caution sign, mine didn't, the only one for me that wasn't showing a driver was Kinect for Windows Camera, just right click it, Update Driver and Browse my computer for driver software then choose Let me pick from a list of device drivers on my computer and select the one that shows up and install it. Everything should work fine after that.

    Optional step: I set my FileRepository folder's permissions to Everyone while doing this and then switched it back afterwards, this doesn't seem to make a difference, but I'm mentioning it just in case.


    Tuesday, August 25, 2015 10:37 AM