locked
Ajax Accordion Control issue RRS feed

  • Question

  • User-960441985 posted

    I am using Ajax accordion control on my .net project. It is always giving me vertical scroll bar regardless of autosize property. by default I used autosize="none" which didn't work. I have tried autosize other options which didn't help. I have set the limit of content to 100% which didn't work.

    I am attaching my code and look forward to know the workaround.

            <ajax:Accordion ID="Accordion1" runat="server" SelectedIndex="1"  HeaderCssClass="accordionHeader"
                                HeaderSelectedCssClass="accordionHeaderSelected" 
                                ContentCssClass="accordionContent" 
                                FadeTransitions="true" 
                                SuppressHeaderPostbacks="true" 
                                TransitionDuration="250" 
                                FramesPerSecond="40" 
                                RequireOpenedPane="false" 
                                AutoSize="None"
                                Height="800px" 
                                Width="100%" 
                                 >
    
    
                
    
                <Panes>
    
                        <ajax:AccordionPane ID="a3" runat="server">
                        <Header> <a href="#" class="href">Release 3</a>   </Header>
                            <Content>
                             <div style="font-size:12pt; font-weight:bold; font-family:Arial;">
                                Release 3 Content
                                </div>
    
                                </Content>
    
                        </ajax:AccordionPane>
    
                        <ajax:AccordionPane ID="a2" runat="server">
                        <Header> <a href="#" class="href">Release 2</a>   </Header>
                            <Content>
                             <div style="font-size:12pt; font-weight:bold; font-family:Arial;">
                                Release 2 Content
                                </div>
    
                                </Content>
    
                        </ajax:AccordionPane>
                   
                    
                    
                    
                </Panes>
    
            </ajax:Accordion>
    
    
    

    Monday, January 9, 2017 3:00 AM

All replies

  • User-707554951 posted

    Hi Ramjee.

    I have tested your code, and when I set AutoSize to “None”, there are no vertical scroll bar appeared.

    I think the scroll bar may created by other factor.  Do you have other setting on accordion?

    Please provide the whole page that I can help you to find the reason.

    Or you can set overflow: hidden to the page to remove the scroll bar.

    Best Regards

    Cathy

    Tuesday, January 10, 2017 8:10 AM