none
WCF Service - Framework 3.5 client does not work with Framework 4.5 hosted WCF Service RRS feed

  • Question

  • Hi,

    I am using WCF service which is upgraded to Framework 4.5.Now the client application built on Framework 3.5 cannot connect to the WCF service built on Framework 4.5.

    It will work  fine if I make the app config entry as below in the client application.

    <?xml version="1.0"?>
    <configuration>
      <startup useLegacyV2RuntimeActivationPolicy="true">
        <supportedRuntime version="v4.0.30319" />
      </startup>
    </configuration>

    But I want to know is there any similar option we can set in the service side that is in the WCF service web. config file so that it can accept the request from the 3.5 framework client.I don't want to force the client application to run on framework 4.5.

    Thanks

    Seena

    Friday, December 20, 2013 7:15 AM

All replies

  • There is no such compatibility issue reported as such.  Would you not mind to post your error message/stack trace here? Enable WCF tracing on both end to track weather there is a connection issue or data serialization issue.

    Lingaraj Mishra

    Friday, December 20, 2013 8:07 AM
  • Hi,

    This is not a connection issue. This is the issue with the external code which we are using for the implementation.The code which we are using will not support client and server running in two different versions.So i would like to know any settings can be done form the Server side to achieve this. Because if i do the app config settings from the client side the code works fine.

    Is there any way if I want to make the same change from the Server side.

    Thanks,

    Seena

    Friday, December 20, 2013 8:49 AM